Problem with portupgrade - SOLVED

Ghirai ghirai at
Fri Apr 6 21:19:20 UTC 2007

Hello Ghirai,

Friday, April 6, 2007, 11:48:29 PM, you wrote:

> Hello Josh,

> Friday, April 6, 2007, 11:08:02 PM, you wrote:

>>> deimos# portupgrade -PR libmpeg2
>>> [Updating the portsdb >format:bdb_btree> in /usr/ports ... - 16851
>>> port entries found
>>> {lines cut} ..... done]
>>> [missing key: categories: Cannot read the portsdb!
>>> database file error
>>> {following some ruby errors regarding the fact that the db can't be
>>> read?!}

>> Try removing (or moving so you have a backup) your
>> /var/db/pkg/pkgdb.db file, then running pkgdb -u to update/create it.

>> Josh

> I did that, it recreated the file w/o errors, but i get the same error
> message.

I did a "make deinstall" and a "make reinstall" for portupgrade, which
bumped the version mumber.

It works now.

Compiling new versions, hopefully everything will turn out ok.

I'll report back.

Best regards,

More information about the freebsd-questions mailing list