Marvell 88SE61xx

Joe Kraft jvk-list at
Thu Apr 5 03:08:21 UTC 2007

Alexander Anderson wrote:
> Thu, Mar 29, 2007 at 10:43:51 PM, Alexander Anderson wrote:
>> Hello.
>> I'm installing FreeBSD 6.2-RELEASE on a brand new system with Intel
>> D975XBX2 board. It seems that FreeBSD does not support the onboard Marvell
>> 88SE6145 SATA controller. Could someone confirm this?
>> At first, when I tried to boot the installation CD, the loader hung very
>> early in the process with the message "BTX halted". But when I went to the
>> BIOS and disabled "Secondary SATA controller" (in Advanced, Peripheral
>> Configuration), the CD booted and the install began alright.
> [snip]
>> Now that I figured out what was causing the "BTX halted" error, I'm going
>> to complete the installation, and then try to enable the Marvell
>> controller back. Let's see if that works.
> No one seems to have replied ...but I'll draw the summary, anyway.
> The installation has completed successfully with Marvell 88SE6145 SATA
> RAID controller disabled. When I go to BIOS and enable it back, the system
> still boots, but dmesg shows no sign of Marvell's presence.
> I'm still not sure if the controller is just not configured correctly or
> if it is not supported under FreeBSD at all, however, I'm leaning towards
> the latter.

I ran into the same problem with my installation on the same mobo.  I 
didn't have to disable the controller or anything, but there needs to be 
a SATA drive connected to port 0 of the controller or SYSINSTALL bombs 
with the BTX halted failure.  I vaguely remember something on this list 
a few months back about that in general, not specifically with this mobo.

I don't remember about the Marvell controller, if it showed up or not. 
It seems it did though, but I might have added something to GENERIC for 
it.  I'm on the road for a while, but if you're still interested I'll 
look when I get home.

Joe Kraft.

More information about the freebsd-questions mailing list