WWW as File and Directory Owner rather than User

Gregory Houston gregory.houston at gmail.com
Tue Apr 3 09:25:51 UTC 2007


My site is hosted on a friend's freeBSD server. I do not have root access. I
do however have full access to MySQL. I am the only one on the server that
uses it. I access MySQL via phpMyAdmin.

Over the last several months I have installed several PHP/MySQL applications
and had no problems.

A couple days ago however I went to install dotProject to try it out, and it
wanted to create its database itself. It didn't want to just populate the
database, but actually create it. To allow it to do this via my username I
had to give myself global privileges. I gave myself all the global
privileges including Grant.

DotProject successfully installed itself. I tried it out, didn't find it to
suit my purposes and then tried to delete it, but found that it had created
files owned by WWW rather than owned by me. Obviously I couldn't directly
delete those files, and had to do so with a PHP script.

My first question is did I somehow give WWW the ability create files and
directories. I have since taken away my global privileges, but when I
installed another app, it also created files and directories with WWW as the

Should WWW be able to be the owner? If not, how do I take its privileges
away? Root is listed as a user in MySQL, as well as myself, but WWW is not.

Now I am afraid to create any new WordPress entries because I don't know if
all my apps are going to start creating files with WWW as the owner rather
than me.

Thanks in advance for any clarification or help on this. I am rather new
with this sort of thing.

Warm regards,


More information about the freebsd-questions mailing list