php5 and SQL Scripts

Martin McCormick martin at
Mon Apr 2 19:51:22 UTC 2007

	About 4 years ago, we installed php from the FreeBSD
ports collection on a system in order to query a MS-SQL data
base on another server.  It worked fine until we upgraded to
FreeBSD6.2 and php5.  I had moved the old binary across and also pulled several
libraries in to /usr/local/lib and the old binary seemed to be
happy until we actually tried to use it at which time it hung
until manually killed.

	After installing /usr/ports/lang/php5 and even trying
/usr/ports/lang/php4, our new php gives the following error:

Fatal error: Call to undefined function mssql_connect()

	Has anybody in the FreeBSD world seen this before and
better yet, how do you fix it?  We do a little piece of a
back-end operation which gathers information from a web
application and uses it to create or remove rules in a firewall.
The folks who own the rest of the pieces of the operation are
asking frequently if it is fixed yet.  I am out of things to
try.  Obviously, something changed between our older system and
the present because the object is either here but in a wrong
directory or I didn't pick the right configuration options in setting
up the port.

	The sql script has worked fine until now for all these

	Any ideas are much appreciated.

Martin McCormick WB5AGZ  Stillwater, OK 
Systems Engineer
OSU Information Technology Department Network Operations Group

More information about the freebsd-questions mailing list