FreeBSD HP Netserver LH 3000 hang at sysinstall

backyard backyard1454-bsd at
Mon Apr 2 16:38:56 UTC 2007


I have an HP Netserver LH 3000 Server w/
2x 800 MHZ pIII
1128 MB RAM (HP Parts)
Integrated Netraid, 4 drives 100 GB of storage

Bios 4.06.33 PT
MMC 10.46
netraid bios 2.04 firmware 1.12
I have scene posts that quote this hardware working
with LH 3000/6000 (2-way piii, 6-way piii xeon)

basically all applied updates available from HP short
of the Ultra3 conversion, which they say don't do
unless your migrating to ultra3; which I will be but
lack the hardware and don't want more mess on my

FreeBSD 6.2-Release, 6.0-Release, and FreeSBIE 1.1 (
Rel_5.4 I think) tried to no avail. Would dig up my
Rel_5.x disks but if FreeSBIE won't work...

I can't boot with ACPI enabled have to hit 2 at loader
screen. which is fine any computer rated at 1.2 KW
isn't going to have power management... although with
the bios updates I think it will work now, but I still
have been hitting 2 most of the time.

Everything works fine until sysintall loads. The
keyboard just doesn't work. Caps lock etc al does
nothing no Leds light up. Sometimes it seems during

"probing devices" 

message the keyboard appears to go through a bus
reset, and it doesn't come back. sometimes it doesn't
appear to reset at all; all leds lighting up and
turning off again is what I mean by reset. I have
tried two keyboards, both do the same.

With FreeSBIE 1.1 I can get as far as 

loading  12454 blocks of 65535

 or soemthing basically when it is loading up the
Ramdrives and that is typed from memeory. usually it
never leaves the splash screen.

I haven't scene anything in my searches as to why I
cannot get this thing to work. the biggest issues seem
to be ACPI and EISA SCSI... I did see one thing on
Interupts but I haven't found it again since.

I have tried disabling SE SCSI, IRQ sharing, turning
netraid back to LVD SCSI, pulling out option boards
I'm not using (2 network cards). I've tried disabling
hot swap PCI resources, changing the sharing methods
from smart to fixed. My guess is the keyboard is
sharing an IRQ with something FreeBSD doesn't like but
I am not sure how to fix that, or if that is even the

I've considered putting jumpers on the hot swap RAID
drives because I know FreeBSD doesn't like
autoenumeration of SCSI devices, but I don't think
this is a storage issue. And this (when I set the
jumpers manually in the past) was a problem with
finding drives not booting into sysinstall

Has anyone had issues like this with FreeBSD on an HP
netserver? I have seriously considered giving up and
installing eComstation and running BSD in a virtual
machine, but I would rather be running BSD on this

Please respond to

backyard1454-bsd (some-kind-of-symbol) yahoo
(a-seperator) com

as I am not on the questions list.

Thanks for any help that can be offered,

Brian McKeon

More information about the freebsd-questions mailing list