Ralink wireless driver help

E. J. Cerejo ejc64 at earthlink.net
Tue Oct 31 02:50:43 UTC 2006

Thanks simon, but I already decided to change to an atheros card, too many 
problems with this one plus no one is working for the betterment of this 
driver any more.

----- Original Message ----- 
From: "Simon Gray" <simon.gray at identrica.com>
To: "E. J. Cerejo" <ejc64 at earthlink.net>
Cc: <FreeBSD-questions at FreeBSD.org>
Sent: Monday, October 30, 2006 8:11 AM
Subject: RE: Ralink wireless driver help


>I just bought a wireless pci card, CNet CWP-854, and according to the
> man page this card is supported.  I compiled a new kernel with 'device

> wlan' and 'device ral' as per the ral man page, it compile without any
> errors, but I can't get it to work.

>If I run: 'ifconfig ral0 inet netmask 0xffffff00 ssid
> 04Z412560727'
>I get this: 'ifconfig: interface ral0 does not exist'
>I run this: 'kldload if_ral'
>I get this: 'kldload: can't load if_ral: File exists'


I'm using an identical card under 6.0-stable without any problems.

Within my kernel I have:

device          wlan
device          an
device          awi
device          ral
device          wi

It might be a silly question - but have you installed the new kernel?

If you have compiled and installed the kernel with support for the
you shouldn't need to load any modules for it.

My kldstat shows:

Id Refs Address    Size     Name
 1   13 0xc0400000 55e1d8   kernel
 2    1 0xc095f000 91f0     bridge.ko
 3    1 0xc0969000 2d90     wlan_wep.ko
 4    1 0xc096c000 41c4     wlan_tkip.ko
 5    1 0xc0971000 6fe4     wlan_ccmp.ko
 6    1 0xc0978000 1bac     wlan_xauth.ko
 7    1 0xc097a000 2ef4     wlan_acl.ko
 8    1 0xc2655000 b000     ntfs.ko

Although I've never got it working properly with wpa/tkip and have
replaced it with a linksys wrt54g. Worked fine for ages with

>I run this: 'pciconf -lv'
>I get this: none1 at pci2:2:0: class=0x028000 card=0x25611814
> rev=0x00 hdr=0x00
>               vendor   = 'Ralink Technology, Corp'

I get:

ral0 at pci0:14:0: class=0x028000 card=0x00201371 chip=0x02011814 rev=0x01
    vendor   = 'Ralink Technology, Corp'
    device   = 'Ralink RT2500 802.11 CardBus Reference Card'
    class    = network



More information about the freebsd-questions mailing list