Can't connect to my wireless network

E. J. Cerejo ejc64 at
Sun Oct 29 13:20:27 UTC 2006

I'm running FreeBSD 6.1 Release and after installing a CNet CWP-854 pci wireless nic and running into some problems with the ral driver I was able to fix that but now I can't connect to my wireless network.

If I run these commands one at a time:

# ifconfig ral0 inet netmask 0xffffff00 ssid My-Network
# ifconfig ral0 inet DHCP ssid My-Network

Nothing happens and if I check it with:

# ifconfig ral0

I get this:

ral0: flags=8803<UP,BROADCAST,SIMPLEX,MULTICAST> mtu 1500
        inet6 fe80::ff:fe00:700%ral0 prefixlen 64 scopeid 0x1 
        ether 02:00:00:00:07:00
        media: IEEE 802.11 Wireless Ethernet autoselect
        status: no carrier
        ssid My-Network channel 1
        authmode OPEN privacy OFF txpowmax 100 protmode CTS

status says no carrier I also notice channel 1 when I'm using channel 6 but I even tried to add the channel to the ifconfig command and still didn't work.  Also where is says ether, I'm assuming this is the MAC address, is not the right mac address for my wireless card, it should be 00-08-A1-A4-E0-EC.  Right now I'm running a complete open network just to test this which later on I will use the "Access list" feature in my router which should not effect it.

More information about the freebsd-questions mailing list