Ralink wireless driver help

E. J. Cerejo ejc64 at earthlink.net
Sat Oct 28 03:14:23 UTC 2006


I just bought a wireless pci card, CNet CWP-854, and according to the ral man page this card is supported.  I compiled a new kernel with 'device wlan' and 'device ral' as per the ral man page, it compile without any errors, but I can't get it to work.

If I run: 'ifconfig ral0 inet netmask 0xffffff00 ssid 04Z412560727' 
I get this: 'ifconfig: interface ral0 does not exist'

I run this: 'kldload if_ral'
I get this: 'kldload: can't load if_ral: File exists'

I run this: 'pciconf -lv'
I get this: none1 at pci2:2:0: class=0x028000 card=0x25611814 chip=0x03011814 rev=0x00 hdr=0x00
               vendor   = 'Ralink Technology, Corp'

I run this: 'dmesg | grep ral0'
I get this: nothing, zip, not a thing.

Sometimes, when I exit fluxbox I see this on the screen: 'Module pci/ral failed to register: 17'

I'm totally confused, does anyone have any idea how to fix this?


More information about the freebsd-questions mailing list