Nvidia on CURRENT...

Tore Lund toreld at netscape.net
Tue Oct 24 04:58:53 PDT 2006

Anders Troback wrote:
> On Tue, 17 Oct 2006 15:14:38 +0200
> Tore Lund <toreld at netscape.net> wrote:
>> Anders Troback wrote:
>>> On Tue, 17 Oct 2006 11:25:05 +0400
>>> "Andrew Pantyukhin" <infofarmer at freebsd.org> wrote:
>>>> I have it working fine on my current. Have you disabled agp in
>>>> kernel config?
>>> No, should I? Running on GENERIC!
>> It's a little easier to try it out by putting this line into
>> /boot/device.hints:
>> hint.agp.0.disabled="1"
> No, no luck!
> This is the error from startx:
> NVIDIA: could not open the device file /dev/nvidiactl (No such file or
> directory).
> (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please
> ensure
> (EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
> (EE) NVIDIA(0): that the NVIDIA device files have been created properly.
> (EE) NVIDIA(0): Please consult the NVIDIA README for details.
> (EE) NVIDIA(0):  *** Aborting ***
> (EE) Screen(s) found, but none have a usable configuration.
> And yes there is a Nvidia GPU in my system (at least when I'm
> running 6.2):-)

Hmmm.  What about dmesg?  Does it report the device nvidia0 or anything
else with nvidia chips?  And are you running nvidia-settings?

The port nvidia-xconfig solved some problems for me by modifying my
xorg.conf.  And I solved a couple of other problems by browsing the
Nvidia knowledgebase:


(Though, I am running 6.1-RELEASE.)

More information about the freebsd-questions mailing list