problems after rebuild of 5.5 stable

Matthew Pope mpope at
Mon Oct 23 00:06:07 UTC 2006

Matthew Pope wrote:

> Lowell Gilbert wrote:
>> Matthew Pope <mpope at> writes:
>> [...]
>>> for temp file for many of the prompts.  Now my 5.5 kernel boots, but
>>> there are a number of messages of the form:
>>> source_rc_confs: not found
>>> $ipnat_enable is not set properly - see rc.conf(5)
>>> $ipfs_enable is not set properly - see rc.conf(5)
>>> etc....
>> [...]
>>> I later read in the mailing list that someone had a simliar problem
>>> and solved it by re-running the mergemaster step.  I tried that too,
>>> and this time I selected <default> answer to all the prompts about
>>> conflicts.
>> The default operation in mergemaster is to do nothing, so if you're
>> going to choose the default the whole way, you might as well skip
>> running mergemaster at all. 
> Yes, well put.  That clarified I was in fact consuming resources in a 
> less than optimal way :-)
>> Go back through mergemaster, and actually
>> pay attention to the changes.  On files you haven't modified, you will
>> be able to (i)nstall the new versions of those files, but otherwise
>> you will need to (m)erge them.
> Ok, I tried that but my system is too far gone.  Close to 100 
> environment vars are missing and if I jam them all into rc.conf it 
> will be a mess, especially since I would be guessing at the 
> appropriate values for the vars.
> My next step is to start from scratch (as Albi suggested.)  
> Unfortuntely, even with ipfw set to open, I am still getting no route 
> to host when I try and ping my gateway.
> It was always pingable in the past, and I've checked the cable into my 
> new-ish switch and all seems fine, with green lights. The result of a 
> route -n is in another virtual terminal and I can't copy and paste, 
> but it lists the headers and then nothing for the details, i.e. no 
> routes are in the routing table at all.

OK pen and paper come to the rescue, here is the result of netstat -n on 
my misconfigured, 5.5 stable, upgraded system that can not seem to ping 
the gateway let alone do a cvsup:

Active UNIX domain sockets
Address    Type   Recv-Q  Send-Q     Inode  Conn  Refs  NextRef  Addr
c20761a4   Stream      0       0     c207a000          0          
0               0     /var/run/devd.pipe

I tried trying ifup sis0 but I discovered ifup is no longer around.

> Further suggestions welcome, and thanks for your help so far.
> Sincerely,
> Matthew
>> _______________________________________________
>> freebsd-questions at mailing list
>> To unsubscribe, send any mail to 
>> "freebsd-questions-unsubscribe at"
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list