Digitemp on freebsd 6.1

leo fante leofante at gawab.com
Thu Oct 19 15:28:26 UTC 2006

I'm trying to use digitemp (http://www.digitemp.com) on freebsd6.1 but my attempt so far is without 

Here what I've done, on a minimal freebsd installation:
downloaded the 3.4.0 tgz, installed gmake, then compiled with "gmake ds9097" (
worked without errors)

./digitemp_9097 -i -s /dev/ttyd0 -q -c ./config
to initialize the program

Digitemp starts and then nothing happens.

I'm using a passive circuit and I've verified that it works. Installed linux on the
same machine and it works.
  I've checked that the serial interface on the freebsd machine works correctly
connecting a serial modem and issuing ati command from minicom. Used root to avoid
problems connected with permissions, chmodded to 777 all /dev/ttyd*, tried ttyd1 the
result is always the same, the program starts without errors and just stays there doing (apparently)
nothing, to exit I've to interrupt the execution.

Since there are no errors I've no other idea of what is wrong.
Any help would be greatly appreciated, thanks

More information about the freebsd-questions mailing list