Routing with external interface doesn't work after a while

Erik Norgaard norgaard at
Wed Oct 18 16:37:56 UTC 2006

Martin Turgeon wrote:

> I've been reading the mailing list for a while, but it's my first post. I'm
> not sure what is causing the problem so I'm posting to multiple lists. I'm
> running FreeBSD 6.1 on a Celeron 2.8GHz with 512Mo of RAM. It looks likes
> after a while (a couple of weeks) the routing isn't working anymore, but
> only with the external interface (the one connected to my cable modem from
> Videotron in Montreal). The box is acting as the gateway of the network with
> PF, OpenVPN 2.0.5-1 and ISC-DHCPd 3.0.3-1 running. The problem also occurred
> on FreeBSD 6.0 on another box.

OK, this can take a long time to solve if the problem reoccurs after 
some weeks - can you reproduce at a faster rate?

> The routing table looks ok.
> The external interface is still receiving ARP requests but nothing is going
> out from my internal network.

OK, so your internal network can't get out. But can you get out from the 
gateway? I mean, try login to the gateway and ping the default gateway. 
Do you get replies? do you see packets going out when sniffing?

> Here's what I tried with no result:
> I tried to flush the states with pfctl -Fs
> I tried to reload the NAT with pfctl -N
> The solution was to renew the address of the external interface with
> dhclient fxp0.
> I looked back at the routing table after the dhclient fxp0 and nothing
> changed except the address of the default gateway because my IP address
> changed of subnetwork.

While the gateway is working take dump output of ifconfig and "route get 
default" into a file. When it stops working do it again. Repeat after 
you have restored the connection.

Did any thing change from it worked till it stopped working?

Cheers, Erik
Ph: +34.666334818                      web:
X.509 Certificate:
Key ID: 69:79:B8:2C:E3:8F:E7:BE:5D:C3:C3:B1:74:62:B8:3F:9F:1F:69:B9

More information about the freebsd-questions mailing list