Routing with external interface doesn't work after a while

Martin Turgeon turgeon.martin at
Wed Oct 18 13:56:02 UTC 2006

Hi everyone,


I've been reading the mailing list for a while, but it's my first post. I'm
not sure what is causing the problem so I'm posting to multiple lists. I'm
running FreeBSD 6.1 on a Celeron 2.8GHz with 512Mo of RAM. It looks likes
after a while (a couple of weeks) the routing isn't working anymore, but
only with the external interface (the one connected to my cable modem from
Videotron in Montreal). The box is acting as the gateway of the network with
PF, OpenVPN 2.0.5-1 and ISC-DHCPd 3.0.3-1 running. The problem also occurred
on FreeBSD 6.0 on another box.


The routing table looks ok.

The external interface is still receiving ARP requests but nothing is going
out from my internal network.

When I run tcpdump on my internal interface I can see the request to the DNS
server of my ISP but running tcpdump on the external interface isn't showing
anything related to that. It's like if the packet disappeared.

Tcpdump on pflog0 isn't showing any good traffic that is being blocked


Here's what I tried with no result:


I tried to flush the states with pfctl -Fs

I tried to reload the NAT with pfctl -N


The solution was to renew the address of the external interface with
dhclient fxp0.


I looked back at the routing table after the dhclient fxp0 and nothing
changed except the address of the default gateway because my IP address
changed of subnetwork.


I don't think it's related to the ISP because I'm not seeing any packet
going out of the external interface.


Here is a little more detail about the box:


Uname -a:

FreeBSD gateway.bureau.own 6.1-RELEASE-p5 FreeBSD 6.1-RELEASE-p5 #2: Fri Sep
15 14:59:44 EDT 2006
root at gateway.bureau.own:/usr/src/sys/i386/compile/OPTIK  i386


The external interface is a Intel 10/100 onboard an Asus motherboard with
fxp driver


Thanks for your help



More information about the freebsd-questions mailing list