ltdl library problems

Chuck Swiger cswiger at
Thu Oct 12 14:03:52 PDT 2006

On Oct 12, 2006, at 1:48 PM, Aaron P. Martinez wrote:
> I am trying to compile a program called gyachi on my freebsd 6.1  
> machine and am having a ton of problems.  I consulted the gyachi  
> forums but most people there are running on one flavor of linux or  
> another, nobody has it on freebsd that i can tell, so now i am  
> turning here.
> at first my configure would stop at alsa, even though i have the  
> linux-compatible alsa programs, so then i used the --with-esd  
> switch and now i'm getting stopped with the following error:  
> checking for lt_dlopen in -lltdl... no configure: error: cannot  
> find ltdl library I have libtool installed and and under /usr/local/ 
> lib i have: libltdl.a I tried  
> using the --with-libintl-prefix switch like so: ./configure -- 
> enable-esd --with-gnu-ld --with-libintl-prefix=/usr/local it's  
> still not finding it, same error again.

Assuming you use a Bourne-compatible shell, try:

	LDFLAGS=-L/usr/local/lib CPPFLAGS=-I/usr/local/include ./configure -- 
enable-esd [ ... ]

If you use csh, use setenv to export the above variables.


More information about the freebsd-questions mailing list