Logitech optical mouse w/ scroll wheel

William Tracy afishionado at gmail.com
Wed Oct 11 14:33:31 PDT 2006


I thought I'd document my experiences with my Logitech optical USB
mouse under FreeBSD 6.1 release 1 so that maybe it will help the next
person hunting with Google. :-)

First off, the moused configuration in sysinstall gave me a headache.
Whenever I tried to test a configuration, the cursor would flicker
onscreen then disappear before I could move the mouse. In frustration,
I selected the option that I thought should work, selected "Yes, the
mouse moves", then shut the computer off.

When I booted FreeBSD the next day, the mouse worked, and I was off on
my way to configuring Xorg.

Next issue: Once I had X up, the mousewheel didn't work. KDE
recognized all three buttons (the mousewheel being the middle button),
but didn't recognize wheel scroll events.

I dredged deep through Google's search results, and found this:


I followed the directions, rebooted (I always screw up when I try to
manually kill daemons--feisty little buggers) and joy came to me that
I would not have to go back to Ubuntu for my mouse to work right.

(Incidentally, the mouse wheel has worked fine under every Linux
distro I've tried except Slackware. Even Gentoo magically detected it.
Go figure.)


More information about the freebsd-questions mailing list