FreeBSD OpenSSL broken

Girish Venkatachalam girishvenkatachalam at
Sun Oct 8 09:30:24 PDT 2006


	I have been seeing scp xfers failing mysteriously with a "Corrupted MAC on input" error. This occurred more or less sporadically but for huge files it was sure to occur. I suspected the ethernet card and got it changed.

	Next, I suspected RAM since I used to get failed compiles saying "internal compiler error" and sefault. This had nothing to do with the other problems since if I issue compile again it used to go thro'.

	And the md5 and sha1 commands never worked. They always used to give corrupted results. Then I just gave up and moved on. I tried installing gentoo on that machine and did a memtest and it went fine.

	Anyway coming to the point, I am running 6.0 FreeBSD.

	I have come across the following cases.

	a) A person in Sweden had trouble with HTTPS and I solved it by reinstalling OpenSSL (check the archives, I think it was more than two months ago)
	b) Recently two persons had severe trouble with OpenSSH

	At last I tried the same medicine I have been prescribing to others and with God's grace :-) , my MD5 and SHA1 started matching...

	I have other machines in LAN running OpenBSD and Debian. I try matching the checksums with those boxes.

	And the only common factor and culprit is ... yes, OpenSSL.

	I urge all of you to make life simpler with this.

# cd /usr/ports/security/openssl
#make deinstall (it may fail, no problem :-)
#make reinstall

	Enjoy guys! :-)

	I might fix the real problem if I get time. Or one of u can too.

	What makes me wonder is how come this problem has gone unnoticed for so long...


More information about the freebsd-questions mailing list