hasbrokenint12=1 AND ata.ata_dma=0 -- no, these are real bad for me

John Soderberg johns at newebmail.com
Thu Jun 29 13:40:57 UTC 2006

I have some blades (from Advent, who by the way, could have been more
helpful.)  When I got them second-hand, they ran Linux.  Which I gladly
wiped out.  I can only run FreeBSD.  Nothing else will work for me.

But in order to boot these boxes up I have to do an option #6 at the
boot-loader prompt, and use 'set';  You probably know the drill.

The thing is, my application is not feasible this way.  I need another
solution.  I tried getting SCSI controllers and disks (and was willing to
just use SCSI in place of DMA) but I discovered that I can't boot these
blades with a SCSI controller in place.  Don't know why, but the machines

I really need help from someone who has dealt with these problems and
solved them.

Now, with an IDE drive, I say:

"set hw.hasbrokenint12=1 AND set hw.ata.ata_dma=0"

(Of course, once I am up, I put these commands in /boot/loader.conf)

and at least, this will make the systems work;  But so slowly as to be
effectively unusable.  For example, FTP transfers operate at about 1MB per
second and a same-disk disk copy of a 20GB file took seven hours.  And
while the copy was happening, the keyboard was hung.  Completely.

If someone knows how to solve these problems, I await your wisdom!

More information about the freebsd-questions mailing list