CUPS, USB printers & "Permission Denied"

Anthony Agelastos iqgrande at
Wed Jun 28 14:10:10 UTC 2006

On Jun 27, 2006, at 9:55 PM, Micah wrote:

> Anthony Agelastos wrote:
>> On Jun 25, 2006, at 11:37 PM, Nicolas Blais wrote:
>>> On Sunday 25 June 2006 23:32, John Nielsen wrote:
>>>> On Sunday 25 June 2006 20:04, Anthony Agelastos wrote:
>>>>> On Jun 25, 2006, at 7:35 PM, John Nielsen wrote:
>>>>>> On Sunday 25 June 2006 19:28, Anthony Agelastos wrote:
>>>>>>> I updated CUPS and I cannot print to my USB laser printer.  
>>>>>>> The web
>>>>>>> interface shows the following:
>>>>>>> hp_LaserJet_1160Le (Default Printer) "Unable to open USB device
>>>>>>> "usb:/dev/ulpt0": Permission denied"
>>>>>>>     Description: Hewlett-Packard LaserJet 1160Le
>>>>>>> Location: Den
>>>>>>> Make and Model: HP LaserJet 1160 Foomatic/hpijs (recommended)
>>>>>>> Printer State: stopped, accepting jobs, published.
>>>>>>> Device URI: usb:/dev/ulpt0
>>>>>>> Doing a `dmesg | grep ulpt0`, I get
>>>>>>> ulpt0: Hewlett-Packard hp LaserJet 1160 series, rev 1.10/1.00,
>>>>>>> addr 2,
>>>>>>> iclass 7/1
>>>>>>> ulpt0: using bi-directional mode
>>>>>>> The printer itself works (I plugged it directly into my MacBook
>>>>>>> and it
>>>>>>> printed fine). To ensure it wasn't an awkward build error, I  
>>>>>>> issued a
>>>>>>> `portupgrade -fR cups`
>>>>>>> and rebuilt it and everything it is dependent upon. Does anyone
>>>>>>> else have
>>>>>>> any ideas? I am running an early 6.1-STABLE (FreeBSD  
>>>>>>> 6.1-RELEASE FreeBSD 6.1-RELEASE #0: Sat May 13 01:04:32 EDT 2006
>>>>>>> root at  i386).
>>>>>> Just a "me too" so far with an el cheapo Lexmark USB laser  
>>>>>> printer
>>>>>> (E210).
>>>>>> Are you using the foomatic script? I am, with a PPD from
>>>>> I am not sure, actually (it was so long ago, I do not remember  
>>>>> how I
>>>>> got it working). I installed hpijs and "Make and Model" mentions
>>>>> Foomatic/hpijs, so perhaps. I am sorry I could not be of more
>>>>> assistance with this question.
>>>>>> I'm going to try backing up and blowing away my etc/cups dir, re-
>>>>>> updating
>>>>>> the port, reinstalling foomatic and my ppd, and see if that  
>>>>>> makes any
>>>>>> difference. I'll post whatever I learn.
>>>>> Thank you for posting your findings and for your quick reply.
>>>> No luck. I basically re-installed everything (including config  
>>>> files and
>>>> the foomatic filters) from scratch. I also changed the permissions
>>>> on /dev/ulpt0 to be 0664 for root:cups. That prevents the  
>>>> permissions
>>>> error, but I still get nothing from the printer. The message  
>>>> that comes up
>>>> in the cups web interface when I try to print a test page is:
>>>> "/usr/local/libexec/cups/backend/usb failed"
>>>> I did get my other printer (on a different machine) working with  
>>>> cups 1.2.0
>>>> by just changing the permissions on the device node. I hadn't  
>>>> ever set this
>>>> printer up with cups before today, though. It's using gutenprint.
>>> After playing with the permissions on ulpt, I can print a test  
>>> page, though
>>> half of it comes out after I manually feed my printer.
>>> After that half-printed page, anything I try to print after will  
>>> get me a "USB
>>> port busy; will retry in 30 seconds..." message and it never prints.
>> My system essentially does the same thing (the 30 second message  
>> that is). After changing my  LogLevel and killing and resubmitting  
>> a test page, here is my error_log file. Does anyone else have any  
>> idea what I can try next? Everyone on this list has been wonderful  
>> with this thread. Thanks again.
> I'm not seeing any errors in the log - assuming that the section  
> that contains the job you mention starts at 19:29:47 on Jun 27th. I  
> see job 9 start and I see job 9 canceled but I don't see any errors  
> in between.
> A completely random thing: have you tried using /dev/unltp0 instead  
> of /dev/ulpt0? It shows up as "USB Printer # (no reset)" in the  
> cups web interface on my system.
> HTH,
> Micah
I just tried /dev/unltp0 and I have the same issues. Basically, I  
killed all of the jobs, made your change, submitted a test page,  
watched as nothing happened (it didn't display any messages in the  
web interface), did a /usr/local/etc/rc.d/cupsd restart, killed the  
test page, then resubmitted one, and then it mentioned the USB busy  
will retry in 30 seconds line. I reattached my error_log for today's  

I will be on the road for the better part of a week, so I will try to  
help out as much as I can given the circumstances. Thank you everyone  
for your assistance with this.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: error_log.bz2
Type: application/octet-stream
Size: 38804 bytes
Desc: not available
Url :
-------------- next part --------------

More information about the freebsd-questions mailing list