Disk Activity Causes Video Stuttering

Simon Morgan simon at 16hz.net
Sun Jun 25 11:00:33 UTC 2006


I'm having trouble with mplayer that seems to be highlighting a bug or general
inefficiency in the ata driver when used with the VIA VT8235 chipset used in
the ASUS A7V8X motherboard.

The problem is that whenever a video is being played and there is any
reasonable amount of disk activity (e.g dd if=/dev/urandom of=test), the video
skips and the mplayer status shows that it's had to drop frames to keep the
video and audio in sync.

I have tested using the same video under NetBSD 3.0 and Linux 2.6.{16|17} and
neither of them exhibit this problem. This also rules out the possibility of it
being faulty hardware.

To be on the safe side I have tried 2 different chipsets of both graphics card
and sound card and neither makes any difference.

I noticed that under Linux hdparm shows it to be using udma4 by default and
udma5 is not even listed as being supported.


# hdparm -I /dev/hda


ATAPI CD-ROM, with removable media
	Model Number:       PIONEER DVD-RW  DVR-108
	Serial Number:      DJDL021894WL
	Firmware Revision:  1.20
	Likely used CD-ROM ATAPI-1
	DRQ response: 50us.
	Packet size: 12 bytes
	LBA, IORDY(can be disabled)
	Buffer size: 64.0kB
	DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 *udma4
	     Cycle time: min=120ns recommended=120ns
	PIO: pio0 pio1 pio2 pio3 pio4
	     Cycle time: no flow control=240ns  IORDY flow control=120ns
	Enabled	Supported:
	   *	DEVICE RESET cmd
	   *	PACKET command feature set
	   *	Power Management feature set
HW reset results:
	CBLID- above Vih
	Device num = 0 determined by CSEL


# atacontrol list
ATA channel 0:
    Master:  ad0 <IC35L060AVVA07-0/VA3OA52A> ATA/ATAPI revision 5
    Slave:       no device present
ATA channel 1:
    Master: acd0 <PIONEER DVD-RW DVR-108/1.20> ATA/ATAPI revision 5
    Slave:       no device present
# atacontrol mode ad0
current mode = UDMA100

I tried changing the mode to udma4 and also to pio but unfortunately it made no

If anybody could offer up some advice or point me in the direction of avenues to
explore I would appreciate it as I've run out of ideas.

Thanks for your time.

Copyright (c) 1992-2006 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 6.1-RELEASE #0: Sun May  7 04:32:43 UTC 2006
    root at opus.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC
ACPI APIC Table: <ASUS   A7V8X   >
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(TM) XP 2000+ (1658.54-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x662  Stepping = 2
  AMD Features=0xc0400800<SYSCALL,MMX+,3DNow+,3DNow>
real memory  = 1073725440 (1023 MB)
avail memory = 1041784832 (993 MB)
ioapic0: Changing APIC ID to 2
ioapic0 <Version 0.3> irqs 0-23 on motherboard
kbd1 at kbdmux0
acpi0: <ASUS A7V8X> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <32-bit timer at 3.579545MHz> port 0xe408-0xe40b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <VIA 8377 (Apollo KT400/KT400A/KT600) host to PCI bridge> mem 0xf0000000-0xf7ffffff at device 0.0 on pci0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
pci1: <display> at device 0.1 (no driver attached)
bfe0: <Broadcom BCM4401 Fast Ethernet> mem 0xd6000000-0xd6001fff irq 18 at device 9.0 on pci0
miibus0: <MII bus> on bfe0
bmtphy0: <BCM4401 10/100baseTX PHY> on miibus0
bmtphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
bfe0: Ethernet address: 00:e0:18:a1:31:f0
ral0: <Ralink Technology RT2500> mem 0xd5800000-0xd5801fff irq 17 at device 14.0 on pci0
ral0: MAC/BBP RT2560 (rev 0x04), RF RT2525
ral0: Ethernet address: 00:0e:2e:5c:2d:0f
uhci0: <VIA 83C572 USB controller> port 0xb800-0xb81f at device 16.0 on pci0
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xb400-0xb41f at device 16.1 on pci0
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <VIA 83C572 USB controller> port 0xb000-0xb01f at device 16.2 on pci0
usb2: <VIA 83C572 USB controller> on uhci2
usb2: USB revision 1.0
uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ehci0: <VIA VT6202 USB 2.0 controller> mem 0xd5000000-0xd50000ff at device 16.3 on pci0
usb3: EHCI version 1.0
usb3: companion controllers, 2 ports each: usb0 usb1 usb2
usb3: <VIA VT6202 USB 2.0 controller> on ehci0
usb3: USB revision 2.0
uhub3: VIA EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub3: 6 ports with 6 removable, self powered
isab0: <PCI-ISA bridge> at device 17.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 8235 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xa800-0xa80f at device 17.1 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
pci0: <multimedia, audio> at device 17.5 (no driver attached)
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xccfff,0xd0000-0xd5fff on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ums0: Microsoft Microsoft 3-Button Mouse with IntelliEye(TM), rev 1.10/3.00, addr 2, iclass 3/1
ums0: 3 buttons and Z dir.
Timecounter "TSC" frequency 1658535371 Hz quality 800
Timecounters tick every 1.000 msec
ad0: 58644MB <IC35L060AVVA07 0 VA3OA52A> at ata0-master UDMA100
acd0: DVDR <PIONEER DVD-RW DVR-108/1.20> at ata1-master UDMA66
Trying to mount root from ufs:/dev/ad0s1a

Never let your schooling interfere with your education.

More information about the freebsd-questions mailing list