problem creating filesystem snapshot

Jon Falconer jfalconer at
Thu Jun 22 18:05:02 UTC 2006


I needed to dump the partitions on a running FreeBSD 6.1R system so I
could duplicate them on a test server. The server is a Dell 2850 with the
PERC 4e/Di RAID controller with 5 x 73GB disk array. So I thought I would
try using the snapshot feature. I used the mksnap_ffs to create a snapshot
of a 20GB partition. The command completed in about 15 - 20 seconds. I was
then able to run dump against the new snap file and all seemed ok. I then
tried the same thing on a 225GB partition. The mksnap_ffs command took
over 30 minutes to complete. But every access to that partition after that
just hung. I wanted to see the size of the snap file so I typed ls -l
/home/.snap (where I had told mksnap_ffs to put the snap file) and it
hung. Same thing from several logins. I figured I would have to reset the
box so I typed sync, and that hung. All the time, access to other
partitions was just fine (/, /usr, /var).

All partitions (except /) were created with soft update enables (default
when installing.) 

The questions. Is there anything magic about the /xxx/.snap directory in
each partition? When I created the snap file for the 20GB partition, I did
not put it inside the /xxx/.snap directory, and it worked fine. Is there
some partition size restrictions?

Thank you for your thoughts,


More information about the freebsd-questions mailing list