scsi cdrom mounting problem

Denny White dennyboy at
Tue Jun 20 21:42:11 UTC 2006

Hash: SHA1

I was having the problem before upgrading from 5.4 to 5.5,
and now, after the upgrade, the problem persists. Now and
then, I can find a cd that'll mount, but most won't. Have
tried the ones that won't mount on this obsd box with atapi
instead of scsi & no problems. Googled around and searched
the archives for the error messages, but didn't find anything
to help so far. Read the man page on camcontrol and the warning
about using it, so checking with the list before I do anything
else. I did find one thing through google about the scsi delay
sometimes needing to be increased, and I made that change in
my kernconf before recompiling, but it didn't help. Tried
booting with kernel.debug just to see what would happen, and
it went smoothly, but this time there was no error message in
dmesg, except that it said there was no medium present, which
wasn't true. There was disk 1 of fbsd 5.5 install in the drive.
When I try to mount a cd, I get `cd9660: /dev/cd: Input/output
error' or sometimes, `device not configured'. Another thing that
confuses me is, I thought in /dev, besides cd0, that there would
be devices like on my obsd box, i.e., cd0a, cd0c, rcd0a, rcd0c,
and so forth. The only cd entry in my fbsd /dev is cd0. I read
some on MAKEDEV and saw that in fbsd 5, it's deprecated, replaced
by devfs. I thought maybe somehow, from some of my earlier upgrades,
that I had screwed up something with devices being created. Below
is some info I've gotten that I hoped would help.

(camcontrol's output)
scbus0 on amr0 bus 0:
scbus1 on amr0 bus 1:
scbus2 on amr0 bus 2:
scbus3 on ahc0 bus 0:
<SEAGATE ST19171W SUN9.0G 0A7E>  at scbus3 target 0 lun 0 (da0,pass0)
<TOSHIBA CD-ROM XM-5701TA 0787>  at scbus3 target 5 lun 0 (cd0,pass1)
<  >                             at scbus3 target -1 lun -1 ()
scbus-1 on xpt0 bus 0:
<  >                             at scbus-1 target -1 lun -1 (xpt0)

(from dmesg.yesterday)
cd0 at ahc0 bus 0 target 5 lun 0
cd0: <TOSHIBA CD-ROM XM-5701TA 0787> Removable CD-ROM SCSI-2 device 
cd0: 10.000MB/s transfers (10.000MHz, offset 8)
cd0: Attempt to query device size failed: NOT READY, Medium not present

(from today's dmesg)
cd0 at ahc0 bus 0 target 5 lun 0
cd0: <TOSHIBA CD-ROM XM-5701TA 0787> Removable CD-ROM SCSI-2 device 
cd0: 10.000MB/s transfers (10.000MHz, offset 8)
cd0: cd present [296521 x 2048 byte records]
(cd0:ahc0:0:5:0): READ(10). CDB: 28 0 0 0 0 0 0 0 1 0 
(cd0:ahc0:0:5:0): CAM Status: SCSI Status Error
(cd0:ahc0:0:5:0): SCSI Status: Check Condition
(cd0:ahc0:0:5:0): MEDIUM ERROR asc:15,0
(cd0:ahc0:0:5:0): Random positioning error
(cd0:ahc0:0:5:0): Retrying Command (per Sense Data)

(had decreased this a long while back to 10000 to speedup boot, and
  increased it today after reading aforementioned in google)
options   SCSI_DELAY=20000   # Delay (in ms) before probing SCSI 5 15 6
kern.disks: da0 cd0 amrd0
          cdev    44    11K     11K       44  256
   allocdirect     0     0K      3K       70  128
debug.sizeof.cdev: 232

I'm currently running FreeBSD 5.4 p2. Anyone replying please let
me know if there's any other info I can provide that'll help.


Denny White

GnuPG key  : 0x1644E79A  |
Fingerprint: D0A9 AD44 1F10 E09E 0E67  EC25 CB44 F2E5 1644 E79A

Version: GnuPG v1.4.2.2 (OpenBSD)


More information about the freebsd-questions mailing list