USB mouse not working...

Bak - bak at
Mon Jun 19 08:39:20 UTC 2006

Hi everybody,

I'm having trouble getting my USB mouse to work on my FreeBSD 6.0.... It 
worked fine before on Windows XP and Ubuntu Linux.

My laptop is a Fujitsu-Siemens Amilo A7640.

The mouse is Microsoft Comfort Optical Mouse 3000.

dmesg gives the following results:



psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
uhid0: Microsoft Microsoft Optical Mouse with Tilt Wheel, rev 2.00/1.20, addr 



As far as I can tell (and I am new to FreeBSD) psm0 is my fingertouch mouse 
and uhid0 is my USB mouse. Other than that I am clueless as to where I edit 
the settings to make the USB mouse functional.

I tried googling but didn't find an answer...

Hope someone can help.


More information about the freebsd-questions mailing list