Python port problems

Alex Zbyslaw xfb52 at
Wed Jun 14 17:10:16 UTC 2006

Joe Auty wrote:

> On Jun 14, 2006, at 6:01 AM, Alex Zbyslaw wrote:
>> Joe Auty wrote:
>>> Sorry for the delay in response here. This is still a problem for  
>>> me,  and I would still like this problem resolved.
>>> Yes, I've tried reinstalling both Python and Mailman, and upgraded  
>>> to  newer port revisions of Mailman which have been released since  
>>> this  message. I'm still getting the same error message when I go  
>>> to start  Mailman via its rc script:
>>> ... snip
>>> Traceback (most recent call last):
>>> :
>>> : No module named getopt  File "/usr/local/mailman/bin/qrunner",  
>>> line  76, in ?
>>>     ImportErrorimport getopt
>>> No module named getopt:
>>> No module named getopt
>>> ImportErrorCould not find platform independent libraries <prefix>
>>> Could not find platform dependent libraries <exec_prefix>
>>> Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
>>> 'import site' failed; use -v for traceback
>>> : No module named getopt
>>> Traceback (most recent call last):
>>>   File "/usr/local/mailman/bin/qrunner", line 76, in ?
>>>     import getopt
>>> ImportError: No module named getopt
>> Honestly, this looks like a screwed python install or some screw up  
>> when mailman compiled.  Can you do a few basic info things?
> Sure, happy to do so!

I've truncated the tests since nothing there showed any problem 
whatsoever.  I'm running out of ideas, so this one may be off the wall:
($ to indicate command lines but don;t type the $ :-))

$ egrep prefix /usr/local/mailman/bin/qrunner

I've found a mailman installation I can compare this next one against.

$ egrep prefix /usr/local/mailman/bin/

If this doesn't look like below, then we have found the problem, if not 
the cause.  If anything contains the <> you have the problem and can 
ignore the next item.  (Yours should have /usr/local for /var but it's a 
cruddy Linux machine which happens to have mailman).

# importing this module, sys.path gets `hacked' so that the $prefix/Mailman
prefix = '/var/mailman'
exec_prefix = '${prefix}'
if exec_prefix == '${prefix}':
    exec_prefix = prefix
# Hack the path to include the parent directory of the $prefix/Mailman 
sys.path.insert(0, prefix)
sys.path.insert(0, os.path.join(prefix, 'pythonlib'))
sitedir = os.path.join(sys.prefix, 'lib', 'python'+sys.version[:3],

And one which may spew quite a lot.  Cut it off if it gets to printing help.

$ python -v /usr/local/mailman/bin/qrunner


More information about the freebsd-questions mailing list