Cyclom-8y on FreeBSD 6.1

fred bloggs johnryan_852 at
Wed Jun 14 16:27:10 UTC 2006


I've got a Cyclom-8y, that was working under Linux, but I can't get any 
communication using FreeBSD.

dmesg says:
cy0 at iomem 0xd4000-0xd5fff irq 9 on isa0
cy0: [FAST]

My devices have all been created automatically:
[root at karang ~]# ls /dev/cuac0*
/dev/cuac00             /dev/cuac01             /dev/cuac02             
/dev/cuac03             /dev/cuac04             /dev/cuac05             
/dev/cuac06             /dev/cuac07
/dev/cuac00.init        /dev/cuac01.init        /dev/cuac02.init        
/dev/cuac03.init        /dev/cuac04.init        /dev/cuac05.init        
/dev/cuac06.init        /dev/cuac07.init
/dev/cuac00.lock        /dev/cuac01.lock        /dev/cuac02.lock        
/dev/cuac03.lock        /dev/cuac04.lock        /dev/cuac05.lock        
/dev/cuac06.lock        /dev/cuac07.lock
[root at karang ~]# ls /dev/ttyc0*
/dev/ttyc00             /dev/ttyc01             /dev/ttyc02             
/dev/ttyc03             /dev/ttyc04             /dev/ttyc05             
/dev/ttyc06             /dev/ttyc07
/dev/ttyc00.init        /dev/ttyc01.init        /dev/ttyc02.init        
/dev/ttyc03.init        /dev/ttyc04.init        /dev/ttyc05.init        
/dev/ttyc06.init        /dev/ttyc07.init
/dev/ttyc00.lock        /dev/ttyc01.lock        /dev/ttyc02.lock        
/dev/ttyc03.lock        /dev/ttyc04.lock        /dev/ttyc05.lock        
/dev/ttyc06.lock        /dev/ttyc07.lock

On port 8 of the card I have connected a Sun console. If I connect with 
minicom using /dev/cuad1 it works fine. If I connect with /dev/cuac07, the 
status line at the bottom of minicom shows "Online", but I get no output on 
the screen. I've tried 2 other ports as well.
I've got a full null modem cable between the Cyclom and the Sun. Exiting 
minicom also takes a long time (about 2 minutes)

I've also set up gettys on 3 ports:
ttyc00  "/usr/libexec/getty std.9600"   vt100   on secure
ttyc01  "/usr/libexec/getty std.9600"   vt100   on secure
ttyc02  "/usr/libexec/getty std.9600"   vt100   on secure

and tried with minicom and hyperterm to connect them, but nothing either.
What else do I need to do to get this working?

Any help appreciated.

Thanks in Advance
John Ryan

Don't just search. Find. Check out the new MSN Search!

More information about the freebsd-questions mailing list