Python port problems

Alex Zbyslaw xfb52 at
Wed Jun 14 10:01:20 UTC 2006

Joe Auty wrote:

> Sorry for the delay in response here. This is still a problem for me,  
> and I would still like this problem resolved.
> Yes, I've tried reinstalling both Python and Mailman, and upgraded to  
> newer port revisions of Mailman which have been released since this  
> message. I'm still getting the same error message when I go to start  
> Mailman via its rc script:
> ... snip
> Traceback (most recent call last):
> :
> : No module named getopt  File "/usr/local/mailman/bin/qrunner", line  
> 76, in ?
>     ImportErrorimport getopt
> No module named getopt:
> No module named getopt
> ImportErrorCould not find platform independent libraries <prefix>
> Could not find platform dependent libraries <exec_prefix>
> Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
> 'import site' failed; use -v for traceback
> : No module named getopt
> Traceback (most recent call last):
>   File "/usr/local/mailman/bin/qrunner", line 76, in ?
>     import getopt
> ImportError: No module named getopt

Honestly, this looks like a screwed python install or some screw up when 
mailman compiled.  Can you do a few basic info things?

which python

whereis python

# and to the command interpreter type
import getopt
# and exit with ^D (control D)

egrep -i -A 2 -B 2 python /usr/local/etc/pkgtools.conf /etc/make.conf

egrep -i -A 2 -B 2 mailman /usr/local/etc/pkgtools.conf /etc/make.conf

head -5 /usr/local/mailman/bin/qrunner


More information about the freebsd-questions mailing list