Python port problems

Joe Auty joe at
Tue Jun 13 19:33:08 UTC 2006

On May 23, 2006, at 12:42 PM, Alex Zbyslaw wrote:

> Lowell Gilbert wrote:
>> Joe Auty <joe at> writes:
>>> $ python -c 'import sys; print sys.path'
>>> ['', '/usr/local/lib/', '/usr/local/lib/python2.4', '/ 
>>> usr/ local/lib/python2.4/plat-freebsd5', '/usr/local/lib/ 
>>> python2.4/lib- tk', '/usr/local/lib/python2.4/lib-dynload', '/usr/ 
>>> local/lib/ python2.4/site-packages']
>>> I don't have a /usr/local/bin/python in there. Is that my problem?
>> That's where the ports would install it, so that does sound like a
>> problem.   Look at "which python" and "pkg_info|grep python".
> The executable /usr/local/bin/python has no business being in the  
> path for *modules*.  This is not your problem.
> I have never used mailman so do not know how it picks up its  
> modules.  It *might* install them into one of these directories on  
> the module patch, but more likely it just pushes its own directory  
> of modules onto this path when it runs, in which case the output  
> you have won't help.
> Have you tried simply re-installing mailman?  Maybe you upgraded  
> python at some point after installing mailman and that is throwing  
> something.

Sorry for the delay in response here. This is still a problem for me,  
and I would still like this problem resolved.

Yes, I've tried reinstalling both Python and Mailman, and upgraded to  
newer port revisions of Mailman which have been released since this  
message. I'm still getting the same error message when I go to start  
Mailman via its rc script:

... snip
Traceback (most recent call last):
: No module named getopt  File "/usr/local/mailman/bin/qrunner", line  
76, in ?

     ImportErrorimport getopt
No module named getopt:
No module named getopt
ImportErrorCould not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback
: No module named getopt
Traceback (most recent call last):
   File "/usr/local/mailman/bin/qrunner", line 76, in ?
     import getopt
ImportError: No module named getopt

Any ideas here?

Joe Auty
NetMusician: web publishing software for musicians
joe at

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
Url :

More information about the freebsd-questions mailing list