FreeBSD 6.0, ThinkPad 600, dc0: watchdog timeout - ACPI?

Fred Koschara freebsd-questions at
Tue Jun 6 05:29:25 UTC 2006

I just purchased another ThinkPad 600 and installed FreeBSD 6.0, expecting 
it would go as smoothly as had my previous installations of FreeBSD on my 
Web, database and nameservers, on the desktop machine on which I'm 
experimenting with FreeBSD programming, and on the Dell Latitude where 
FreeBSD is one of the 5 operating systems I have installed.  The 
installation did, indeed, seem to go smoothly.  However, network 
connectivity is an issue:  Any time I try to do something that would 
connect to the network (ntpd checking for time servers, sendmail starting 
during the boot process, ftp, ping) I get dc0 watchdog timeout errors, and 
most of the time nothing else.  When I ping the network gateway, nothing 
happens for several seconds, then ping reports response times of 8.77~, 
7.77~, 6.77~, ..., 0.77~ seconds in a batch, then "goes to sleep" again, 
repeating the sequence.

I made the mistake of trying to start Gnome with this problem 
occurring.  When, over an hour later, I was able to *finally* get to where 
I could shut the desktop down gracefully, I resolved to not do *that* 
exercise again!

This laptop came with two PCMCIA network cards - an IBM 10/100 EtherJet 
CardBus 32-bit adapter, and a 3Com 3C574-TX 10/100Base-TX 16-bit 
adapter.  The EtherJet is the one I'm getting the dc0 watchdog timeout 
errors with.  When I try the 3Com, the boot process reports that it's 
detected the card, but it doesn't make a network connection.  I tried the 
D-Link DFE-690TXD I use all the time in my w98 ThinkPad.  FreeBSD 
recognized the card, but did not attempt to configure it or make a network 
connection.  I also tried a D-Link DWL-G630 AirPlus G wireless card, which 
FreeBSD didn't even know was there, as well as a D-Link DWL-AB650 AirPro 
A/B wireless card.  FreeBSD acknowledged the presence of the AB650, but 
said there was no driver attached.

The EtherJet works correctly with both w2K on my Lattitude, and under w98 
on my other ThinkPad (once I downloaded the drivers).

During the boot process, FreeBSD properly discovers the network card and 
seems to be configuring it, including negotiating the IP address with the 
DHCP server.  Immediately after printing the MAC address, a bold text line 
is written saying "dc0: link state changed to DOWN" and it writes the two 
remaining lines ("media: Ethernet autoselect (none)" and "status: no 
carrier").  There have been times when another bold line was printed later 
saying "dc0: link state changed to UP", but the condition did not persist, 
because I was getting dc0: watchdog timeout errors before the boot process 
was done in those cases as well.

I tried using ifconfig to force the EtherJet into 10Mbps mode, as well as 
full and half duplex, but none of those changes seem to have made any 
difference.  I also added "media 100baseTX mediaopt full-duplex" to the 
ifconfig_dc0 line in rc.conf.  This changed the reported "Ethernet 
autoselect (none)" to "Ethernet 100baseTX <full-duplex>" as expected, but 
the "status: no carrier" keeps coming up.

When I boot FreeBSD with ACPI disabled (option 2), it reports several 
unknown devices in the PCI PnP scan (not surprising) - and the EtherJet 
works correctly.  (Gnome comes up quickly, also.)  However, when I boot 
with ACPI enabled (option 1), the EtherJet cannot connect.  I booted with 
verbose logging, and noticed a couple of things:  There are 4 devices, in 
addition to the cardbus device, assigned to irq 9 (which is the irq being 
used for the network connection, from what I can see), and FreeBSD says the 
cardbus device is 16 bits, not 32 bits.

The man dc(4) page says the dc%d: watchdog timeout error can happen if the 
device is unable to deliver interrupts for some reason, or if there is a 
problem with the network connection.  If there was a problem with the 
network connection, I would expect to the lights on the switch (a D-Link 
DSS-8+) to not be showing a solid network connetion, but this isn't happening.

When Gnome is starting, it also reports "No volume control elements and/or 
devices found."  I thought this might be related to whether ACPI was active 
or not, but the same error message is displayed in both cases.  I don't 
know if this is a related issue or not.

uname -a reports
"FreeBSD 6.0-RELEASE #0: Thu Nov  3 09:36:13 UTC 
2005     root at x64.samsco.home:/usr/obj/usr/src/sys/GENERIC  i386"

Please advise if any further information would be helpful in resolving this 
problem - should I send the verbose dmesg output?  dmesg with and without 
ACPI, for comparison?

Thanks for any suggestions and support!

-- Fred Koschara

Ignorance can easily be cured by knowledge, stupidity is generally only 
cured by death...

Truth and Falsehood were bathing. Falsehood came out of the water first and 
dressed herself in Truth's clothes. Truth, unwilling to put on the garments 
of Falsehood, went naked.
(Author Unknown)

The "war on terror" is a sham:  There is no real protection against 
suicidal maniacs spurred on by creative madmen.  In the end, the only 
outcomes will be the destruction of the American economy due to pouring a 
bankrupting stream of wealth into a bottomless pit, and the final 
destruction of personal liberty in the name of "security."  (When was the 
last time you were asked for "Your papers, please?" - er, that is, "License 
and registration?")

FKE Internet, Web hosting for space related businesses<br>
	Domain registration - $15.95/year, $29.95 for 2 years

For private sector (commercial) space development, visit
For your daily dose of art, try
L5 Software Development - "out of this world" sites and software
How much did your last traffic ticket cost you?
FredLines(tm), T-Shirts For the Thinking Mind(tm)

More information about the freebsd-questions mailing list