Cannot delete stubborn files

David J Brooks daeg at
Sun Jun 4 09:19:36 PDT 2006

On Sunday 04 June 2006 08:11, Jack Stone wrote:
> Hello:
> I have 2 files that resists all efforts to delete them. I can even move
> them to another directory, but still cannot delete. Can chmod too, but
> still same resistance;
> I originally figured they occupied a bad spot on the HD, but now not sure
> about that.
> Please, any suggestions about what to do to remove these files?
> Here are the files and the error message:
> rm: local/lib/perl5/5.6.1/mach/Sys/ Operation not permitted
> rm: local/lib/perl5/5.6.1/mach/Sys/ Operation not permitted
> I've gone all the way down to the last dir and tried to delete them there.
> No joy!
> All directories in between only include the dirs and no files. I want to
> delete the entire path of directories, but those 2 stubborn files will not
> permit that.
> rm: local/lib/perl5/5.6.1/mach/Sys: Directory not empty
> Please, any help appreciated!

I had a similar problem recently with some a directory created on the fly by 
ktorrent. Everytime I tried to delete them they would appear in the trashcan, 
I would flush them, and sooner or later the directory and all its files would 
be right back where they started.

I finally noticed that they reappeared everytime I restarted ktorrent. So I 
went poking under the hood and found a reference to them in deep down in 
~/.kde/share/apps/ktorrent/cache folder. Apparently ktorrent was recreating 
empty files in anticipation of downloading a torrent that was no longer in 
the queue. 

Perhaps something similar is going on with your machine?

Sure God created the world in only six days,
but He didn't have an established user-base.

More information about the freebsd-questions mailing list