Makefile for rpm-4.0.4_4

RAW solsyst at
Sat Jun 3 15:48:11 PDT 2006

This question is about a FreeBSD port that I cannot automake.

Dear FreeBSDers;

Tried to obtain, make and install Port rpm-4.0.4_4, on my new FreeBSD 
6.0. Not there yet Looks like the Makefile program got down to 
"post-patch:", became unhappy, informed me with error code 127, (???) 
and quit.Make claimed that it could not find the shell script 
"configure" (see log below), but when I follow the path to the file, 
there it is. It left an "extract done.rpm-4" doc empty.

How can I get the makefile to continue, find "configure" and finish the 
make job?

P.S. I ran Make in a terminal window on my KDE desktop. Matters?

Thanks for the help.

Make log:

# make install clean
===>  Vulnerability check disabled, database not found
=> rpm-4.0.4.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch from
fetch: File 
unavailable (e.g., file not found, no access)
=> Attempting to fetch from
rpm-4.0.4.tar.gz                              100% of 5728 kB 2370  Bps 
===>  Extracting for rpm-4.0.4_4
=> Checksum OK for rpm-4.0.4.tar.gz.
===>  Patching for rpm-4.0.4_4
===>  Applying FreeBSD patches for rpm-4.0.4_4
-e 's:%%LOCALBASE%%:/usr/local:'  /usr/rpm/rpm4/work/rpm-4.0.4/configure 
-e: not found
*** Error code 127

Stop in /usr/rpm/rpm4.

More information about the freebsd-questions mailing list