Unable to Startx Following Upgrade--Error in Locking Authority File

Bob Perry rperry at gti.net
Mon Jan 30 08:52:22 PST 2006

Lowell Gilbert wrote:
> Bob Perry <rperry at gti.net> writes:
>> Hi everyone,
>> I'm running FreeBSD 5.4-RELEASE #0 and just completed weekly upgrade.
>> Now when I run "startx", I can not connect to the graphical display
>> window.  I simply see the gray screen with the small x in the middle.
>> I went back to the command line to review the text immediately
>> following the startx command and the first line reads: xauth: creating
>> new authority file /home/rperry/.serverauth.8414; then, repeated four
>> (4) times is the following:
>>     /usr/X11R6/bin/xauth:  error in locking authority file
>> /home/rperry/.Xauthority
>> (skip)
>>     error opening security policy file
>> /usr/X11R6/lib/X11/xserver/SecurityPolicy
>>     AUDIT: Sat Jan 28...8433 X: client 1 rejected from local host
>>     Xlib: connection to ":0.0" refused by server
>>     Xlib: No protocol specified
>> I have no problem running startx as root.
>> cd /home/rperry
>> ls -l .Xauthority
>> -rw-------1 root rperry 112 Jan 28 22:13 .Xauthority
>> FWIW, also had trouble running portupgrade due to repeated timeouts
>> and/or loss of connections.
>> Is there a location that lists the error messages like the one I
>> encountered?  Tried Google and the mailing list archives but wasn't
>> able to resolve the issue.
>> Any assistance would be appreciated.
> Sounds like you have a stale authority file.  Try just deleting it
> before the next time you start up...
Bingo! It works...but what is a stale authority file and how do you 
avoid them?


More information about the freebsd-questions mailing list