Mysql on freebsd strange core dumps

Mihai Tanasescu mihai at
Sat Jan 28 15:12:44 PST 2006


I'm running a mysql server   mysql-server-4.1.16 on a FreeBSD 
6.0-RELEASE-p1  and I'm constantly getting this:

pid 82947 (mysqld), uid 88: exited on signal 11 (core dumped)

(about 10-15 times a day).

I ran the gdb debugger on the core dump and saw the following:

Loaded symbols for /libexec/
#0  0x2856365d in pthread_mutexattr_init () from /usr/lib/
[New Thread 0xd66cc00 (LWP 100090)]
[New Thread 0xa9cfe00 (LWP 100207)]
[New Thread 0xaa66c00 (LWP 100201)]
[New Thread 0xab1b400 (LWP 100188)]
[New Thread 0xa9cfa00 (LWP 100205)]
[New Thread 0xd5f8200 (LWP 100203)]
[New Thread 0xab1be00 (LWP 100204)]
[New Thread 0xaa66800 (LWP 100193)]
[New Thread 0xa926000 (LWP 100109)]
[New Thread 0xa90aa00 (LWP 100120)]
[New Thread 0xa90a600 (sleeping)]
[New Thread 0xa90a400 (sleeping)]
[New Thread 0xa90a200 (sleeping)]
[New Thread 0xa90a000 (sleeping)]
[New Thread 0x8454e00 (sleeping)]
[New Thread 0x8454c00 (sleeping)]
[New Thread 0x8454a00 (sleeping)]
[New Thread 0x8454800 (LWP 100053)]
Cannot get thread info: generic error

Sorry for the long paste.

Has anyone got any idea on how this might get fixed ?

One thing I haven't tried again is to resync the sources and recompile  
the system base. (as libpthread seems to be part of the base system).

More information about the freebsd-questions mailing list