X.org 6.9 doesn't work with NVidia 7800 GTX (fwd)

Kevin Oberman oberman at es.net
Thu Jan 26 14:21:16 PST 2006

> Date: Thu, 26 Jan 2006 13:35:55 -0800
> From: Mike O'Brien <mikeobrien at spamcop.net>
> Kevin Oberman wrote:
> >>From: mikeobrien at spamcop.net (Mike O'Brien)
> >>Date: Thu, 26 Jan 2006 07:44:43 -0800
> >>Sender: owner-freebsd-stable at freebsd.org
> >>If I run X -probeonly,
> >>I get a message that "module fbdev cannot be found".
> >>
> >I installed nvidia-driver and nvidia-xconfig. It worked
> >immediately. nvidia-xconfig modifies the existing xorg.conf (or
> >XF85Config) to work with the nvidia driver.
> >  
> >
>     Do I need to worry about "module 'fbdev' not found"?
> That doesn't sound good and makes me wonder if X.org
> might be misconfigured out of the box.

fbdev is not used. You should not have it listed in the "Modules"
section. Several other modules are gone as their functionality has been
rolled into the base system. I suspect fbdev is such a obsolete.

If in doubt, use Xorg -configure and let nvidia-xconfig put in the nVidia
specific config into the output.
R. Kevin Oberman, Network Engineer
Energy Sciences Network (ESnet)
Ernest O. Lawrence Berkeley National Laboratory (Berkeley Lab)
E-mail: oberman at es.net			Phone: +1 510 486-8634

More information about the freebsd-questions mailing list