X.org 6.9 doesn't work with NVidia 7800 GTX (fwd)

Kevin Oberman oberman at es.net
Thu Jan 26 11:29:10 PST 2006

> From: mikeobrien at spamcop.net (Mike O'Brien)
> Date: Thu, 26 Jan 2006 07:44:43 -0800
> Sender: owner-freebsd-stable at freebsd.org
>     I sent this to "freebsd-x11" and didn't hear a peep back,
> so I'm widening the net.
>     I'm running FreeBSD 6-STABLE, cvsupped as of last night.  I upgraded
> the ports collection to X.org 6.9 at the same time.  Under the X
> that ships with 6-RELEASE, in the ISO image, and under X.org 6.9,
> the symptoms are the same.
>     The hardware is an Athlon 4400+ CPU on an Asus motherboard and an
> NVIDIA 7800 GTX video card.
>     I'm not running the NVidia FreeBSD driver (yet), preferring to see
> the VESA work first before stirring the pot.  If I run X -probeonly,
> I get a message that "module fbdev cannot be found".  This message
> is, however, almost unreadable because the probing of the video
> card causes the console contrast to drop almost to zero.  The room
> has to be almost pitch-black before the remaining dim text can be
> read.  I have to reboot the machine to make the console brightness
> and contrast normal again.

I have the same chipset and CPU on an MSI mobo and had exactly the same
problem. Right down to the very low contrast video. I think VESA is
broken with this chipset.

I installed nvidia-driver and nvidia-xconfig. It worked
immediately. nvidia-xconfig modifies the existing xorg.conf (or
XF85Config) to work with the nvidia driver.
R. Kevin Oberman, Network Engineer
Energy Sciences Network (ESnet)
Ernest O. Lawrence Berkeley National Laboratory (Berkeley Lab)
E-mail: oberman at es.net			Phone: +1 510 486-8634

More information about the freebsd-questions mailing list