Setting up a microphone

Keith Beattie KSBeattie at
Tue Jan 24 09:35:28 PST 2006

On 01/24/06 07:11, uidzero wrote:
> It's worked flawlessly for me after I add recompiled the kernel with 
> sound support. (I use Skype as well.)

Thanks and glad to hear that Skype is working.  Listening to music, etc. 
works just fine for me too, it's how to get input from the mic which I'm 
stuck on.  The machine is dual boot so I know the hardware works and the 
things are plugged into the right place (Skype works when running XP). 
This must be a FreeBSD config thing.

I've tried, unsuccessfully, working with mixer, rawrec, wmrecord and 
audacity to capture sound, so I'm now looking for a simple 'is your 
microphone working' test akin to the 'cat some_small_file > /dev/dsp' 
for testing noise coming out of the speakers (which still works).

'cat /dev/dsp > foo', speaking for a bit into the mic, then cntl-c to 
stop, does create a non-empty file but then a 'cat foo > /dev/dsp' 
doesn't produce any sound.  The rawrec port seems promising but no love 
from 'rawrec foo.raw' / 'rawplay foo.raw'.  All this with mixer showing 
non-zero levels for all channels and trying it with the recording source 
as mic and then line.  Something's gotta give here.

> Maybe try updating to RELEASE-p8?

Indeed I'll update anyway but I don't believe any of those patches are 
sound related.


More information about the freebsd-questions mailing list