user accounts messed up

Marcel de Reuver marcel at
Sat Jan 21 12:34:39 PST 2006

   Jona Joachim wrote:

I did something quite stupid...
I installed postgresql from ports and created an unprivileged user
account for it. I wanted to install the database in /var/pgsql and
wanted to chown the folder to the unprivileged user.
To do this, I entered the following as root: chown -R /var/pgsql/
As this command took more than two seconds I presumed chown had
followed .. and so I hit Ctrl-C. After having done this I tried to
switch to the unprivileged user account with su and it said something
like "setuid not running". After having tried to recover from this
situation without success I decided to reboot the system. Now I can't
login to any user account anymore, not even root. I am told the
password is not correct. I tried to boot in single user mode, mount
/usr and change the root password with passwd but I am denied
permission to change master.passwd. Is it possible that the user
database is corrupt? I would be glad if anyone was able to help me.
Greetings, Jona

   In single user mode the file system is mouted readonly. You have to
   remount all the file systems read-write.

More information about the freebsd-questions mailing list