cannot ping anything

Alvaro J. Gurdián AJGurdian at
Fri Jan 20 10:27:04 PST 2006

Yesterday I placed an HD with Freebsd 5.3 release in a Dell Dimension 
L800CXE.  It booted properly. ( since it's running a generic kernel 
with only a name change)

However I could not ping anything inside or outside the LAN.
ping: cannot resolve Hostname lookup failure

ping: sendto: No route to host

I tried several addresses inside the LAN,, localhost,, and all gave the same result.

I was previously using this HD in another machine to test IPF, with NAT 
also, and it worked peerfectly there.

So just to be safe I erased the contents of /etc/rc.conf, and then used 
sysinstall to bring up my NIC.  I  chose NO for IPv6, and YES for DHCP.

That seemed to work correctly, just to be sure I ran ifconfig:
	inet netmask 0xffffff00 broadcast
	ether 00:80:ad:81:1a:9f
	media: Ethernat autoselect (100baseTX)
	status: active
plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
lo0: flags=8049<UP,LOOPBACK,SIMPLEX,MULTICAST> mtu 1500
	inet netmask 0xff000000

Still, things are looking good; so, I go to another box, log into my 
router(, and I can see the MAC address of the BSD box on my 

However, I still get the same results when I ping as I did above.

Then I checked the routing tables:

netstat -r
Routing Tables

Destination	Gateway			Flags	Refs	Use	Netif	Expire
default		UGS		0	6	dc0
localhost		localhost			UH		1	37	lo0
192.168.1		link#1			UC		0	0	dc0	00:0c:41:bd:49:7d	UHLW	1	0	dc0	695	localhost			UGHS	0	0	lo0

The output of netstat and ifconfig aboe are from today.  I began having 
this problem yesterday, and left the box on over night.  Yesterday's 
output was different in that the BSD box had a different IP address,  That is fine I understand that the box is communicating 
with the router and negotiating leases when they expire.  However, why 
has the gateway to changed from link#1 to the MAC address 
of my router.  I am certain that if  I restart the computer that same 
gateway will revert to link#1.

The my questions are:
How do I get the system to see others in the network, and vice-versa?
What should the gateway for be?(which also happens to be my 
routers address)

I am hoping it is something simple.  I could just as have easily 
reinstalled the system and started from scratch, but I wanted to know 
how to solve this problem.

Other info that might help:
less /etc/rc.conf

less /etc/resolv.conf

less /etc/hosts
::1	localhost	localhost

Thanks in advance

More information about the freebsd-questions mailing list