Resolving Perl 'make test' Errors?

David Marshall dmarshall at
Fri Jan 20 04:06:08 PST 2006

We're running perl 5.8.7_2 (from ports), with a mix of modules
installed via ports and CPAN, all on a 6.0-STABLE machine.

Someone tried to install WWW::Mechanize from CPAN, and when it tried
to do a 'make test', there was an error.  If I build the module in
ports and go into the work directory and run 'make test' manually, I
get the same test error.

I usually prefer to install Perl modules through ports when possible,
so that portupgrade can take care of them for me.  However, one of the
shortcomings of the (at least default) way in which ports installs
Perl modules is that ports does not run 'make test'.

Is there a clever way to have the ports system run 'make test' before
installing a Perl module?  Most of the /usr/ports/*/p5-*/Makefile
files do not have 'test' defined as a target.

Does anyone have any advice for how to go about ironing out this
problem?  My first inclination is to remake each of my p5-* ports and
run 'make test' on them manually and then have CPAN reinstall
everything that we have installed via CPAN.

Thanks in advance!

More information about the freebsd-questions mailing list