I belong to too many groups

Matt Emmerton matt at gsicomp.on.ca
Wed Jan 18 19:40:13 PST 2006

> It took me so long to get onto this list that in the end I just gave and
> reinstalled over the top of the old one. It all works now, but I would
> be interested in a way around the problem if one exists. The original
> problem is described below
> I recently installed FreeBSD 6 RELEASE onto a hard drive and added two
> users, bob and bill.
> Whilst I was doing this I decided to make root and bob members of ALL the
> groups in the system.
> I now find that I am unable to log in as either root or bob nor can I su
> from bob.
> I have tried booting to safe mode but it will still not allow me to do
> anything
> The messages that I get from the system are:
> login: ROOT LOGIN (root) ON ttyv0
> login: initgroups(root,0) : Invalid argument
> login: setusercontext() failed - exiting
> I can still log in as bill and this will allow me to see the system files
> but bill doesn't have the authority to change anything.
> I tried to su to root but bill is not in the wheel group.
> If I want to run a graphical environment (and I do) then I need to start
> this up as root.
> Is there any way to get past this problem or will I need to reinstall?

Boot in single-user mode (type "boot -s" at the boot prompt).  Then you will
be "root" and can fix up your /etc/group files.

Matt Emmerton

More information about the freebsd-questions mailing list