Strange Failure Mode in FreeBSD 4.11

Martin McCormick martin at
Thu Jan 12 08:35:03 PST 2006

	I built a FreeBSD 4.11 system recently which is to be remotely
installed in another town.  The system worked on our network while I
tested it and installed several ports, etc.  We then moved it to the
town where it is supposed to live and now, there's big trouble.

	The Ethernet interface, known as em0 on this system, comes up
According to all the messages.  If, however, you try to use it, it is
as dead as a stone.  If I try to ping the local host from root, I get this:

ping: sendto: Permission denied
ping: sendto: Permission denied
ping: sendto: Permission denied

	I get the same response when trying to ping real hosts over
the network.

	Pinging that system from a known good system is like pinging a
disconnected Ethernet jack in that absolutely nothing happens.

	I am lucky in that I can get in to this system via a serial
cable from the known good system so I can see the world from the bad
box, but I have frankly never seen this mode of failure before and am
at a loss as to what to look at.  It had worked perfectly here and all
our folks in the other town did was plug it in and hook up the
Ethernet.  I am glad I sort of have 60-mile-long arms right now, but
this is not good.

	If I do an ifconfig em0, the settings return as they were set
in rc.conf.  The router address is correct and the fact that one can't
ping either tells me that something really nasty happened
somewhere along the way.

	Any ideas as to what I can test next?

	Thank you.

Martin McCormick WB5AGZ  Stillwater, OK 
OSU Information Technology Department Network Operations Group

More information about the freebsd-questions mailing list