ip_icmp.h strange problem

SPYRIDON PAPADOPOULOS SP373 at student.apu.ac.uk
Tue Jan 10 04:09:16 PST 2006


I am include ip_icmp.h to a program. The icmp struct in there is exactly the same with the one on:
(this is just the first exactly the same struct i found online)
I am using FreeBSD 5.4-RELEASE #1

I have already included header files like tcp.h, ip.h, udp.h etc in my program.

Now when i am trying to compile my program with the command:
#gcc -o capTool capTool0.1 -lpcap

it gives me syntax errors, where n_short values appear: lines: 60, 61, 67, 68 and 89 (in my ip_icmp.h).
       71, 72, 78, 79 and 100 (on the online one).

After changing the first four to "u_short ..." it compiles properly...
This also happened with some value in ip.h. However i am not sure which one now, because i changed it and it worked immediately (so i didn't even note what exactly i changed..and since it worked to be honest i didn't mind)
the problem is with the value in line 89:
n_time its_otime;    /* Originate */

even if i change that to:
 u_time its_otime; /* Originate */
it still gives me syntax error before "n_time" or "u_time"

Can anyone help and explain briefly - if possible - how is this happening? I cannot believe that the n_* values are wrong, but are working when changing them to u_*.
I like getting involved with the system header files...but it doesn't really look appropriate to me ;o), or it is?

This message is written quickly in case the problem is known. I can provide with any required information if needed.

Please advice
thank you in advance
Spiros Papadopoulos 

More information about the freebsd-questions mailing list