Postgresql 8.0 again

Benjamin Thelen bt at
Mon Jan 9 04:35:21 PST 2006

Reboot always helped for me. Otherwise see
Maybe this helps.


Mike Jeays schrieb:
> I just re-installed postgresql80-server from the ports, and get exactly
> the same error as from the package.  This is on my 5.4 machine, were I
> previously had a working copy.
> I have tried changing max_connections in the sample config file (setting
> it down to 1 just to see if even that would work). I also tried the
> following kernel setting changes (without a reboot), with no
> improvement.
> sysctl -w kern.ipc.shmall=32768
> sysctl -w kern.ipc.shmmax=134217728
> sysctl -w kern.ipc.semmap=256
> Error message from initdb
> ...
> ...
> creating configuration files ... ok
> creating template1 database in /usr/local/pgsql/data/base/1 ... FATAL:
> could not create semaphores: No space left on device
> DETAIL:  Failed system call was semget(1, 17, 03600).
> HINT:  This error does *not* mean that you have run out of disk space.
>         It occurs when either the system limit for the maximum number of
> semaphore sets (SEMMNI), or the system wide maximum number of semaphores
> (SEMMNS), would be exceeded.  You need to raise the respective kernel
> parameter.  Alternatively, reduce PostgreSQL's consumption of semaphores
> by reducing its max_connections parameter (currently 10).
>         The PostgreSQL documentation contains more information about
> configuring your system for PostgreSQL.
> child process exited with exit code 1
> initdb: removing data directory "/usr/local/pgsql/data"
> Any more help will be very welcome!
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list