i915G and agp

jbw jbwalters at gmail.com
Sat Jan 7 03:27:10 PST 2006


I recently re-installed FreeBSD on my PC after checking out gentoo for
a month or two. I am running 6-STABLE.  My machine has a i915G
graphics chip which does not appear to be recognized and doesn't load
the agp driver at boot time.  Before gentoo I had 5-STABLE on this
machine and it worked fine.

device agp is in my kernel configuration file. I have tried adding the
load statements to loader.conf.  and it still doesn't load agp.

My dmesg output is

pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0xe898-0xe89f mem 0xdff00000-0xdff7ffff,0
xc0000000-0xcfffffff,0xdfec0000-0xdfefffff irq 16 at device 2.0 on pci0
vgapci1: <VGA-compatible display> mem 0xdff80000-0xdfffffff at device 2.1 on pci
pcib2: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
pci2: <ACPI PCI bus> on pcib2

The output from pciconf -vl is

hostb0 at pci0:0:0:        class=0x060000 card=0x01811028 chip=0x25808086 rev=0x04
    vendor   = 'Intel Corporation'
    device   = '82915G/GV/GL/P/PL/GL Grantsdale Host Bridge/DRAM Controller'
    class    = bridge
    subclass = HOST-PCI
pcib1 at pci0:1:0: class=0x060400 card=0x00000088 chip=0x25818086 rev=0x04 hdr=0x01
    vendor   = 'Intel Corporation'
    device   = '82915G/P/PL Grantsdale Host-PCI Express Graphics Bridge'
    class    = bridge
    subclass = PCI-PCI
vgapci0 at pci0:2:0:       class=0x030000 card=0x01811028 chip=0x25828086 rev=0x04
    vendor   = 'Intel Corporation'
    device   = '82915G/GV/GL, 82910GL Integrated Graphics Device'
    class    = display
    subclass = VGA
vgapci1 at pci0:2:1:       class=0x038000 card=0x01811028 chip=0x27828086 rev=0x04
    vendor   = 'Intel Corporation'
    device   = '82915G/GV/GL, 82910GL Graphics Controller (??)'
    class    = display
pcib2 at pci0:28:0:        class=0x060400 card=0x00000040 chip=0x26608086 rev=0x03
    vendor   = 'Intel Corporation'
    device   = '82801FB/FR/FW/FRW PCI Express Port 1'
    class    = bridge
    subclass = PCI-PCI

Any help would be appreciated.



More information about the freebsd-questions mailing list