Problem burning/mounting cd-rom

Frank Staals frankstaals at
Thu Jan 5 07:04:58 PST 2006

Leonidas Tsampros wrote:

>On Thu, Jan 05, 2006 at 01:46:40PM +0100, Frank Staals wrote:
>>I have an Acer Aspire 1356 LCi laptop with a CD-RW/DVD-drive in it so I 
>>can burn cds and read DVD's and cd's. But when I tried to burn and mount 
>>a datadisk this happend:
>>frank at Riza$ mkisofs -o tmp1.iso totaal.wmv
>>24.61% done, estimate finish Thu Jan  5 13:37:10 2006
>>49.25% done, estimate finish Thu Jan  5 13:37:10 2006
>>73.82% done, estimate finish Thu Jan  5 13:37:10 2006
>>98.49% done, estimate finish Thu Jan  5 13:37:10 2006
>>Total translation table size: 0
>>Total rockridge attributes bytes: 0
>>Total directory bytes: 0
>>Path table size(bytes): 10
>>Max brk space used 8724
>>20320 extents written (39 MB)
>>frank at Riza$
>>root at Riza# burncd -f /dev/acd0 -s 12 data tmp1.iso fixate
>>next writeable LBA 0
>>writing from file tmp1.iso size 40640 KB
>>written this track 40640 KB (100%) total 40640 KB
>>fixating CD, please wait..
>>root at Riza# mount_cd9660 -v /dev/acd0 /mnt/dvd/
>>could not determine starting sector, using very first session
>>mount_cd9660: /dev/acd0: Input/output error
>>root at Riza#
>>I'm using a Philips CD-RW which I cleaned before use with:
>>root at Riza# burncd -f /dev/acd0 erase
>>erasing CD - 99 % done    
>>I tried searching what I could do about it, but I couldn't realy find 
>>something usefull. It seems that something goes wrong with burning the 
>>CD I guess ( looking at the output when trying to mount it ) but I'm not 
>>sure what I do wrong. Everything worked fine up until today. I hope 
>>someone can point out what I can do about it.
>>Thanks in advance,
>The overall process seems to ended quite succesfully. Just try to
>eject the cd before mounting the fresh cd that you burned. I had
>similar issues very recently and this was the solution for me. 
>If you are bored to death, try these:
># burncd -f /dev/acd0 (blabla)
> (wait to finish)
># cdcontrol -f /dev/acd0 eject
># cdcontrol -f /dev/acd0 close
># mount_cd9660 -v /dev/acd0 /mnt/dvd
Hmm I got a little bit further indeed, but it still won't mount

<burned the cd>

root at Riza# cdcontrol -f /dev/acd0 eject

<manually pushed the cd-drive back ( since it is a laptop ) >

root at Riza# mount_cd9660 -v /dev/acd0 /mnt/dvd/
using starting sector 0
mount_cd9660: /dev/acd0: Input/output error
root at Riza#

-Frank Staals

More information about the freebsd-questions mailing list