Kernel Compilation...

Crispy Beef crispy.beef at
Thu Jan 5 01:55:05 PST 2006

>>Still sounds like a hardware problem. Maybe the laptop is overheating,
>>compiling software is always hard on a system. Also I don't think
>>Memtest86 will show you anything even if your ram is bad. The best way
>>to find out is to just change it out if you have extra somewhere or
>>remove part of it and/or shuffle it around.
>>Check for thermal issues, maybe build the kernel with the laptop in
>>the refrigerator or something :-). If you do something like that make
>>sure you don't get condensation buildup when you take it out of the
>>cold and into the warm... but the humidity is always low in the winter
>>so it shouldn't be to much of a problem.
> One more thing. You said this was an older laptop (400ish MHz) right?
> If so you better double check that ACPI is working and that the
> thermal trip points are set correctly. I had a major problem with an
> Armada 1750 (PII-M at 366MHz i440BX) in that ACPI was totally broken.
> FreeBSD 5.x would never trip the fans on. The system hit would 100C
> (212F) and then FreeBSD would auto shutdown the system. I sold the
> laptop after I found that out and bought a better one, an Omnibook
> 6000 (PIII at 700MHz with 440BX). I still had major problems with ACPI so
> I decide to just install SuSE 9.3 Pro on it. SuSE worked perfect.

466MHz P2 Celeron with 128Mb RAM on an i440BX mobo.  The system won't boot 
unless it's with ACPI enabled, just panics during start-up.

> FreeBSD's ACPI implementation and laptops with i440BX/MX or earlier
> chipsets don't mix well. sysctl will help you with the thermal
> settings and will help if you need a new
> DSDT. this will help some too:

Actually thinking about it now I've got this system running you could be 
right, since then I've had to get my PCMCIA network card running properly, 
whenever it gets plugged in the kernel panics, did some research and found 
that by putting debug.acpi.disabled="sysresource" into the /boot/loader.conf 
file that it works just fine, so as you say there definitely seems to be some 
issues with ACPI.

You can hear the CPU fan wind up and down while the system is running, that's 
something I don't remember from having Gentoo compiling...that always worked 
just fine, so it could well be a heat issue.  The chipset on the laptop is an 
Intel i440BX jobbie.

Will look into the thermal thing now, cheers.

More information about the freebsd-questions mailing list