Kernel Compilation...

Crispy Beef crispy.beef at
Tue Jan 3 07:11:51 PST 2006

Jonathan Chen wrote:
> On Mon, Jan 02, 2006 at 04:15:48PM +0000, Crispy Beef wrote:
>>Hi All,
>>Just joined this list.  The last time I used FreeBSD was with 4.6-RELEASE, 
>>so a while ago now.  I have just installed 6.0-RELEASE on my old laptop and 
>>have been configuring the system, am onto the kernel at the moment, have 
>>followed the traditional method in the FreeBSD handbook.  All works fine 
>>(make depends) until I do 'make' then I get a compilation error as follows:
>>internal compiler error: Segmentation fault: 11
>>Please submit a full bug report,
>>with preprocessed source if appropriate.
> Internal compiler errors usually indicate faulty memory. If you rerun
> your compilation and it fails in the same spot, then it could be
> software. If the compilations fails in a different area, you've
> probably got faulty hardward.

It's looking very much like faulty hardware at the moment...bit of a shame 
really.  Have used Gentoo Linux on this machine before (compiling from source) 
and that's always worked just fine, I only ditched it a couple of weeks ago to 
have a play with FreeBSD again.

Also tried the memtest86 util from a floppy, that doesn't even boot properly 
so looks like it might be a no go.  :-/


More information about the freebsd-questions mailing list