snd_neomagic crashes on FreeBSD 5.4

Lila liladude at
Sun Feb 26 06:04:09 PST 2006

sorry for troubling you, I'm and absolute FreeBSD beginner and I need some
help with configuring devices.
Last week I tried to install FreeBSD on my laptop, a Omnibook 900, wich has
been consdered "FreeBSD Compatible" long time ago.
Everything was fine, at least I can access my FreeBSD login and even run
KDE, but it is far from being tuned.
I first notice each time I try to kldload snd_neomagic to have my sound card
working I have a prompt  saying:

pcm0: <NeoMagic 256AV> mem 0xfe700000-0xfe7fffff,0xfe00000-0xfe3fffff irq 10
at device 0.1 on pci1

and system frozes. The same happens if i try to statically compile
snd_nemagic into kernel.

I started checking all IRQ and settings: I know audio must use IRQ 5 for
multimedia devices, and IRQ 10 shared with cardbus and USB, for audio, I
tried to add lines on device.hints but having pcm0 on pci1 is useless.
vmstat -i says cbb0 and cbb1 are on irq 10, but says nothing about usb (wich
works properly) or pcm

I also noticed my serial port (sio0) is not probed.
Any suggestion? should I try anything to debug it better?
Thanks a lot

Here is my dmesg if anybody can found it of any use

Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
 The Regents of the University of California. All rights reserved.
FreeBSD 5.4-RELEASE #0: Sun May  8 10:21:06 UTC 2005
    root at
module_register: module uhub/umass already exists!
Module uhub/umass failed to register: 17
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Pentium II/Pentium II Xeon/Celeron (297.79-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x66a  Stepping = 10

real memory  = 100663296 (96 MB)
avail memory = 88715264 (84 MB)
pnpbios: Bad PnP BIOS data checksum
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <HP-MCD CJ RSDT> on motherboard
acpi0: Power Button (fixed)
unknown: memory range not supported
unknown: memory range not supported
unknown: memory range not supported
unknown: memory range not supported
unknown: memory range not supported
acpi_ec0: <Embedded Controller: GPE 0x9> port 0x66,0x62 on acpi0
Timecounter "ACPI-safe" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x8008-0x800b on acpi0
cpu0: <ACPI CPU (3 Cx states)> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
acpi_lid0: <Control Method Lid Switch> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82443BX (440 BX) host to PCI bridge> at device 0.0 on pci0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
pci1: <multimedia, audio> at device 0.1 (no driver attached)
cbb0: <TI1225 PCI-CardBus Bridge> at device 4.0 on pci0
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
cbb1: <TI1225 PCI-CardBus Bridge> at device 4.1 on pci0
cardbus1: <CardBus bus> on cbb1
pccard1: <16-bit PCCard bus> on cbb1
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 UDMA33 controller> port
0xfcf0-0xfcff,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 7.1 on pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port 0xfcc0-0xfcdf irq 10
at device 7.2 on pci0
usb0: <Intel 82371AB/EB (PIIX4) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
pci0: <bridge> at device 7.3 (no driver attached)
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
acpi_acad0: <AC Adapter> on acpi0
acpi_cmbat0: <Control Method Battery> on acpi0
acpi_cmbat1: <Control Method Battery> on acpi0
fdc0: <floppy drive controller (FDE)> port 0x3f7,0x3f2-0x3f5 irq 6 drq 2 on
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ppc0: <ECP parallel printer port> port 0x778-0x77f,0x378-0x37f irq 7 drq 3
on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/7 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on
sio0: type 16550A
orm0: <ISA Option ROM> at iomem 0xc0000-0xcbfff on isa0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 297786406 Hz quality 800
Timecounters tick every 10.000 msec
TUPLE: LINKTARGET [3]: 43 49 53
Manufacturer ID: d11302ab
Functions: Network Adaptor, Memory
Function Extension: 0102
Function Extension: 0280969800
Function Extension: 0200e1f505
Function Extension: 0301
Product version: 5.0
Product name: Neteasy | DRP-32TXD Cardbus PC Card | V1.0 |  |
TUPLE: Unknown(0x04) [6]: 03 01 2a 00 00 00
cardbus0: Opening BAR: type=IO, bar=10, len=0100
cardbus0: Opening BAR: type=MEM, bar=14, len=0400
CIS reading done
cardbus0: Non-prefetchable memory at 88000000-880003ff
cardbus0: IO port at 1000-10ff
cardbus0: <network, ethernet> at device 0.0 (no driver attached)
ad0: 38154MB <IC25N040ATMR04-0/MO2OAD4A> [77520/16/63] at ata0-master UDMA33

More information about the freebsd-questions mailing list