repost: Incorrect superblock

Dave dmehler26 at
Tue Feb 21 23:38:33 PST 2006

    Some urgency on this issue! Here's some additional details not sure the 
last msg went through.

    I've got a 10 gb ide drive that has critical data on one of it's
partitions /dev/ad1e. This drive was originally gmirrored in
another box it worked fine, it was the master drive. Now i've
installed this drive as a slave in another 6.0 box, and now it
shows up as ad1 with the partition i want being ad1e. I did a mount it 
worked fine. So i knew the drive was working, i then unmounted the 
partition, and tried to dump it to another drive. This didn't work, dump got 
an error about incorrect superblock. I then did a mount
-o ro /dev/ad1e /mnt and i'm getting an error "Incorrect
superblock" from mount. I then tried fsck /dev/ad1e and got the
same error msg. These partitions were formatted with ufs2 as their
filesystem. I then ran bsdlabel ad1 and got a printout of my label,
this showed up which gives me hope that this data can be retrieved.
An error i'm getting from bsdlabel says that the c: partition does not cover 
> entire disk and that may result in utilities not working correctly. Any 
> help appreciated.
    Some urgency!

Script started on Sun Feb 19 07:56:47 2006
root at webserver:/dev#ls ad1*
ad1 ad1a ad1b ad1c ad1d ad1e ad1f ad1g
root at webserver:/dev#fdisk /dev/ad1
******* Working on device /dev/ad1 *******
parameters extracted from in-core disklabel are:
cylinders=19386 heads=16 sectors/track=63 (1008 blks/cyl)

Figures below won't work with BIOS for partitions not in cyl 1
parameters to be used for BIOS calculations are:
cylinders=19386 heads=16 sectors/track=63 (1008 blks/cyl)

Media sector size is 512
Warning: BIOS sector numbering starts with sector 1
Information from DOS bootblock is:
The data for partition 1 is:
The data for partition 2 is:
The data for partition 3 is:
The data for partition 4 is:
sysid 165 (0xa5),(FreeBSD/NetBSD/386BSD)
    start 0, size 50000 (24 Meg), flag 80 (active)
 beg: cyl 0/ head 0/ sector 1;
 end: cyl 1023/ head 254/ sector 63
root at webserver:/dev#bsdlabel /dev/ad1
# /dev/ad1:
8 partitions:
#        size   offset    fstype   [fsize bsize bps/cpg]
  a:   266240       16    4.2BSD     2048 16384 16648
  b:   524288   266256      swap
  c: 19541024        0    unused        0     0         # "raw" part, don't 
  d:  7340032   790544    4.2BSD     2048 16384 28552
  e:  8388608  8130576    4.2BSD     2048 16384 28552
  f:  2097152 16519184    4.2BSD     2048 16384 28552
  g:   921600 18616336    4.2BSD     2048 16384 57608
bsdlabel: partition c doesn't cover the whole unit!
bsdlabel: An incorrect partition c may cause problems for standard system 

Script done on Sun Feb 19 08:02:34 2006

More information about the freebsd-questions mailing list