apsfilter question/problem

Denny White dennyboy at cableone.net
Fri Feb 17 12:48:19 PST 2006

Hash: SHA1

Today Mike Jeays spake forth boldly:

> On Fri, 2006-02-17 at 11:09 +0000, Denny White wrote:
>> I read the article at Onlamp about printing for the impatient.
>> Installed apsfilter and samba on my old hp netserver so I'd
>> be able to print to an hp 722c deskjet printer connected to
>> an xp box. Gimp-print was also installed. Ghostscript was
>> already installed. I ran /usr/local/share/apsfilter/./SETUP
>> & thought I had it whipped. That's where the fun started.
>> Apparently I've missed something along the way, since the
>> print job never gets sent to the xp box. I also found out
>> at linuxprinting.org that the recommended hp 722c driver
>> is pnm2ppa. There was only one section in the install script
>> that mentioned that driver, 10) PPA printer, so I chose that.
>> It plugs it into the setup, but when I try to print a test
>> page, I get ERROR: additional filter 'pnm2ppa' not found.
>> I found the driver at linuxprinting.org & downloaded it.
>> How do I go about using it? Is there a way to compile it
>> into ghostscript? I have ghostscript-gnu-nox11-7.07_14 &
>> the apsfilter setup script found it & didn't complain.
>> Do I need to install another more complete version? I know
>> if I install ghostscript-afpl, I'll also have to recompile
>> & reinstall apsfilter with the proper make options. When
>> I choose the more generic just plain deskjet printer driver,
>> the script accepts it, and when I try to print a test page,
>> there's no complaining about the driver like when I try the
>> ppa driver. Test page is created, supposedly sent to the
>> xp printer with even a speed, average around 950 kb/s, but
>> I see where it only goes to stdin. I'm definitely not a
>> programmer, but another filter, ghostscript, something, has
>> to relay it to stdout, is that correct?
>> So, I could use some pointers on this. If anyone interested
>> in answering needs more info, I'll be glad to plug it in to
>> a reply. Like smb.conf, apsfilterrc, & so forth. Thanks.
>> Denny White
> -------------------------------------------------------------
> # Printcap file: Added 2005-04-25 based on pnm2ppa suggestions.
> lp|ascii|unix:\
>                :lp=/dev/lpt0:\
>                :sd=/var/spool/lpd:\
>                :if=/home/mike/bin/pnm2ppa-filter:\
>                :mx#0:\
>                :sh:
> -------------------------------------------------------------
> #!/bin/sh
> # printcap-filter
> TMP=/tmp/pnm2ppa.tmp
> cat >$TMP
> ch1=`head -1 $TMP | cut -c 1`
> if [ "$ch1" = '%' ]
> then
> cat $TMP | /usr/local/bin/gs -sDEVICE=ppmraw -q -dNOPAUSE -r600 \
> -sOutputFile=- - | \
> /usr/local/bin/pnm2ppa -i - -o -
> else
>  cat $TMP | /usr/local/bin/enscript -B -q -p - | \
>  /usr/local/bin/gs -sDEVICE=ppmraw -q -dNOPAUSE -r600 \
>  -sOutputFile=- - | \
>  /usr/local/bin/pnm2ppa -i - -o -
> fi
> rm $TMP

> -- 
> Mike Jeays
> http://ca.geocities.com/mike.jeays@rogers.com

Thanks for the answer, Mike. Will have to try working with
this when I get off work in the a.m. Have no idea how to
incorporate it with the smb stuff. I know that there's a
basic apsfilterrc in /usr/local/etc/apsfilter & then separate
apsfilterrc's for each individual printer in separate subdirs,
along with smbclient.conf. I've tried reading samba logs, &
/var/log/messages to try & figure out what I'm doing wrong.
This whole thing started because of me not wanting to have to
scp files to the xp box & then having to go there to physically
enter printer commands. Laziness prevailed. If I ever get this
working, it'll be worth it. In the meantime, I think it took
less energy walking. :)
Denny White

GnuPG key  : 0x1644E79A  |  http://wwwkeys.nl.pgp.net
Fingerprint: D0A9 AD44 1F10 E09E 0E67  EC25 CB44 F2E5 1644 E79A

Version: GnuPG v1.4.1 (OpenBSD)


More information about the freebsd-questions mailing list