devfs rule: ioctl DEVFSIO_SAPPLY: No such process (???)

FreeBSD Prospect mailings.freebsd at
Fri Feb 17 01:42:06 PST 2006


I am trying to get the OSS soundsystem working for my nforce2 mainboard since 
yesterday, but with mixed success. The OSS driver is generally setup 
correctly and working, which means osstest outputs the demosound.

My problem now seems to be the devfs, because I am trying to apply the ruleset 
to the audio devices in /dev, so that a normal user can access the sound in 

I used the following code for /etc/devfs.rules (which are given in this forum 

add path 'dsp*' mode 666 
add path 'mixer*' mode 666 
add path 'audio*' mode 666 
add path 'midi*' mode 666 
add path sequencer mode 666 
add path music mode 666 
add path dmfm0 mode 666

The ruleset should be processed by the startscript by calling:

/sbin/devfs rule -s 200 applyset 

but this command only outputs:

devfs rule: ioctl DEVFSIO_SAPPLY: No such process

and nothing happens to the device nodes in /dev. I already tried to play 
around with devfs & devfs.rules, but whatever I tried, either it only gives 
the above error message, or simply gives no feedback and does nothing.

If I run "/etc/rc.d/devfs restart", nothing happens.
If I run "devfs ruleset 200 && devfs rule applyset" no feedback, and no change 
in /dev.

I tried a similar approach for changing ownership and perms for /dev/acd* with 
another ruleset, I found on this mailinglist, but exactly the same result.

For some reason unknown to me, devfs seems not be working on my system. I did 
nothing special on this installation. Installed from the 6.0-RELEASE 
install-cd, updated world to 6.1-PRERELEASE, installed the latest OSS driver 
package, configured it for nforce2, osstest OK, installed KDE by ports, and 
now I am stuck to get sound working in KDE...

Any comments?


A FreeBSD Prospect, who is actually using Gentoo Linux

More information about the freebsd-questions mailing list