FreeBSD 6.0, amd64, A8N-SLI and 4gb ram

Robert Leftwich freebsd at
Thu Feb 16 13:48:15 PST 2006

Joseph Kerian wrote:
> I was planning on purchasing one of these boards in the near future, so I'm
> rather interested if you have solved this particular problem. In no
> particular order, my suggestions are:
> -The A8N-SLI's are extremely picky about the RAM you give them; have you
> double checked with a memtest run to verify that it's not the problem? 

No, but I think it is purely down to the bios to enable the last 1gb or not. If 
I disable both the h/w and s/w PAE options in the bios then the bios only 
reports 3gb available and FreeBSD the same and it runs ok (sans the memory leak 
problem I've also emailed the question list about - with little response).

If I enable *only* the h/w PAE option in the bios, both it and FreeBSD report 
4gb available, but FreeBSD is visibly slower on startup, the nic doesn't appear 
to work correctly (DHCP fails) and it is very flaky after login.

If I enable *only* the s/w PA option in the bios, both it and FreeBSD report 4gb 
available, but FreeBSD fails to complete startup, spewing 'entry of nVidia 
Mediashield metadata is NOT supported' on the console until manually rebooted.

> Also,
> what happens if the new RAM is the only RAM in the system?

Everything works as expected (2gb available/used), no problems encountered.

> -Does anything change if you compile for a single processor? FreeBSD should
> run fine even if it's not taking advantage of the dual cored nature of the
> processor.

Haven't tried that, but I have the original kernel on the box, so I will.

> -There appears to have been a bios problem with using exactly 4 gigs of ram
> in the A8N Deluxe boards at one point, not sure if this also showed up on
> the Premiums or not. You may want to verify that you are running the most
> recent bios.

Yep, I'm running 1009 which is the latest non-beta version.

> I found the cause of the invalid option error.  From the handbook section on
> the PAE option:
> "*Note:* The PAE support in FreeBSD is only available for Intel IA-32
> processors." Note that it appears that PAE is a system for addressing _more_
> than 4 gigs of RAM (handbook section 8). Since your board only supports up
> to 4 gigs (
> I guess I'm curious why the PAE options exist in the bios.

The bios help(!) says '4gb or more' and it appears to be the only way to get it 
to enable the last 1gb.

After some discussion on the Ubuntu 64 forum I'm going to try the Live CD 64 bit 
to see if it boots up ok with the 4gb turned on in the bios and if so, it looks 
like I will have to move to that distro to get this box working properly.


More information about the freebsd-questions mailing list